cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Lucas" <j...@stonecottage.com>
Subject Re: Java 2 dependencies(Compile problems)
Date Tue, 11 Jan 2000 21:45:44 GMT
If that's the case, then then shouldn't the building of XSP be a different
target in build.xml.  That way, everyone wins.. (I think)


josh
----- Original Message -----
From: Ted <ted@gs2admin1.e-meet.com>
To: <cocoon-dev@xml.apache.org>
Sent: Tuesday, January 11, 2000 1:21 PM
Subject: Re: Java 2 dependencies(Compile problems)


> I am developing in Voice Markup Language, and I *DO* need the URLDecoder
> class which is implemented in Java 2 only. (In fact, we had to upgrade
> all servers to be able to do this). Although the consensus in this list
> seems to be compatibility with 1.1, I think that those who wish to
> deploy the most recently added XSP functionality should use Java 2.
>
> Ricardo, back me up on this one :-)
>
> Ted
>
> Joshua Lucas wrote:
> >
> > I am having probelm compiling the latest from CVS.  I had updated then
had
> > problems so I went back and checked everything out.  I believe the
problem
> > is that some code related to XSP is using Java 2 methods and classes.
> >
> > Here are the errors:
> >
/usr/home/jolucas/xml-cocoon/build/src/org/apache/cocoon/processor/xsp/XSPUt
> > il.java:376:
> > Undefined variable or class name: URLDecoder
> >     return URLDecoder.decode(text);
> >            ^
> >
/usr/home/jolucas/xml-cocoon/build/src/org/apache/cocoon/processor/xsp/langu
> > age/java/XSPClassLoader.java:83:
> > Method getParent() not found in class
> > org.apache.cocoon.processor.xsp.language.java.XSPClassLoader.
> >           ClassLoader cl = getParent(); // Hmmm...
> >
> > Is Java 2 now a requirement?  I looked back through the archives and
didn't
> > find anything but maybe I missed it.
> >
> > thanks,
> > josh
>


Mime
View raw message