cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett McLaughlin <>
Subject Re: can't build latest CVS
Date Wed, 22 Dec 1999 23:18:57 GMT

Donald Ball wrote:
> > This actually will work at runtime for either JSDK 2.0 or 2.1+.  That's
> > the whole idea here, is that as compiled code it works on multiple
> > platforms, so we _don't_ have to keep multiple copies of the file.
> Right, but we had previously agreed that it would be too burdensome to
> force people to have JSDK2.1+ in their classpath for developing and
> JSDK2.0 in their classpath for running their servlet engine. If we want to
> change that agreement, that's fine, but I'd prefer it to be an agreement
> rather than a proclamation.

Absolutely.  I was under the <mistaken /> impression that the agreement
was the other way around.  My apologies, everyone...

> The pros of doing it this new way are obvious and compelling. The cons
> are:
> 1. this is yet another hurdle for new developers to get
> confused/frustrated over, thus limiting our noosphere.

OK, although I have to admit that I am proud to say most of the
Cocoon-ites I have seen so far are fairly advanced, at least the ones
working from source... can anyone other than Donald and I speak up on
your feelings here?

> 2. easy to start relying on JSDK 2.1+ methods without noticing it

This one I am more dubious on... the only real nice 2.1+ thing that I
can see being used much in Cocoon-land is RequestDispatcher or maybe
getServletContext() type stuff.  Again, I think most of our developers
are pretty cognizant of these things.  However, that said, you have very
valid points, and I certainly don't want to lose even one Cocoon user
over these sort of (really, trivial) issues.

> > your classpath at compile time.  IMHO this is a reasonable
> > request/sacrafice for someone building from source.  You have to have
> > lots of packages that aren't needed at runtime, such as the GNU and FESI
> > stuff, and these aren't nearly as easy to find as the JSDK (later
> > versions).  So I think this is OK as is.  You want to compile from
> > source, you can get JSDK 2.1 ( or
> > JSDK 2.2 ( with Tomcat [servlet.jar]), and then
> > you can deploy Cocoon on either JServ or 2.0 envrinonments, or Tomcat
> > and 2.1+ environments.
> I don't think that we _should_ have to have FESI, etc. to compile cocoon.

So how about this for a compromise?  If you want to load Cocoon in your
IDE and compile the whole thing, you have to have all this extra stuff
(e.g. JSDK 2.1+, FESI, GNU, etc).  Basically if you are doing this
-sans- Ant, you are saying you accept the risks/difficulties.

However, we provide Ant build scripts to build everything with _just_
the stock classes (leaving out all the GNU/FESI/JSDK 2.1+ stuff).  This
is for the user who want to muck with the source, but not so much that
they have to download all these extra classes.  Sound like a happy

Of course, if it does, we are back to your original query, do we need
two copies of that class for the Ant stuff... and I don't have a good
answer.  People, comments?  Your input is a big factor on this stuff...

> - donald


View raw message