cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett McLaughlin" <bmcla...@algx.net>
Subject Re: Different problem compiling 1.6-dev
Date Thu, 09 Dec 1999 21:25:05 GMT

> IDE? With Linux? NEVER! I love my command line (but maybe I'm too old for
> this :-).

;-)

>
> > Re-read Donald's e-mail.  This is the same thing he and
> > anyone using Ant gets right now.  For now, build with Ant
> > doesn't work.  Use an IDE instead, or wait on Ant.
> > I personally use an IDE and have much better luck.
>
> Even with that, I get:
>
> ../org/apache/cocoon/parser/SunXMLParser.java:44:
> class com.sun.xml.tree.XmlDocument is an abstract class.
> It can't be instantiated. return new XmlDocument();

Never seen this... do you have the latest projectx_tr2.jar?

>
> ../org/apache/cocoon/producer/ProducerFromMap.java:90:
> Wrong number of arguments in method.
> Document sitemap = parser.parse(new InputStreamReader
> (new FileInputStream(sitemap_file)),sitemap_path);
>
> ../org/apache/cocoon/producer/ProducerFromMap.java:124:
> Wrong number of arguments in method.
> Document document = parser.parse(new InputStreamReader
> (new FileInputStream(file)),"");

These two are Donald with a work-in-progress, don't worry about them.


>
> ../org/apache/cocoon/EngineWrapper.java:83: inner class
> org.apache.cocoon.EngineWrapper. HttpServletRequestImpl
> is an abstract class. It can't be instantiated.
> this.handle(new HttpServletRequestImpl(pathToDocument),
> new HttpServletResponseImpl(out));
>
> ../org/apache/cocoon/EngineWrapper.java:87: inner class
> org.apache.cocoon.EngineWrapper. HttpServletRequestImpl
> is an abstract class. It can't be instantiated.
> this.handle(new HttpServletRequestImpl(documentPath,
> document), new HttpServletResponseImpl(out));
>
> ../org/apache/cocoon/EngineWrapper.java:95: inner class
> org.apache.cocoon.EngineWrapper. HttpServletRequestImpl
> must be declared abstract. It does not define boolean
> isRemoteUserInRole(java.lang.String) from interface
> javax.servlet.http.HttpServletRequest.
> public class HttpServletRequestImpl implements
> HttpServletRequest {

I submitted a patch for these yesterday that Donald committed.  Do a cvs
update and these will go away.

>
> Note: ../org/apache/cocoon/producer/ProducerFromMap.java
> uses or overrides a deprecated API.  Recompile with
> "-deprecation" for details.

This is just the way it goes... and you're using > 2.0 of the Servlet API.

-Brett


Mime
View raw message