cocoon-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anathan...@apache.org
Subject svn commit: r555090 - /cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf
Date Tue, 10 Jul 2007 21:49:11 GMT
Author: anathaniel
Date: Tue Jul 10 14:49:10 2007
New Revision: 555090

URL: http://svn.apache.org/viewvc?view=rev&rev=555090
Log:
Add sample to show that XSPs allow Java5 syntax, if running under a 1.5+ JVM

Modified:
    cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf

Modified: cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf
URL: http://svn.apache.org/viewvc/cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf?view=diff&rev=555090&r1=555089&r2=555090
==============================================================================
--- cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf
(original)
+++ cocoon/trunk/blocks/cocoon-xsp/cocoon-xsp-impl/src/main/resources/META-INF/cocoon/avalon/cocoon-xsp-program-language.xconf
Tue Jul 10 14:49:10 2007
@@ -37,11 +37,11 @@
       <!--+
           | Specifies which Java compiler to use. Possible variants are:
           |
-          |  - EclipseJavaCompiler: the Eclipse JTD java compiler
+          |  - EclipseJavaCompiler: the Eclipse JDT java compiler
           |  - Javac: the java compiler that comes with JDK
           |  - Jikes: the Jikes java compiler
           |
-          | NOTE: the Eclipse JTD is the only java compiler that is capable
+          | NOTE: the Eclipse JDT is the only java compiler that is capable
           |       of imports classes thru the context classloader. All other
           |       compilers import classes from the JVM classpath and might
           |       normally result in ClassNotFound problems at compilation
@@ -62,8 +62,7 @@
           | auto = The version of the JVM where cocoon is running. (Default value).
           |
           | NOTE: The parameter is optional to keep backward compatibility.
-          |       The parameter currently works only with Sun Javac compiler.
-          |       The eclipse compiler version 3.0.1 currently does not support java 1.5.
+          |       The parameter works with Sun Javac compiler and the Eclipse compiler.
           +-->
       <!-- <parameter name="compiler-compliance-level" value="auto"/> -->
     </java-language>



Mime
View raw message