cocoon-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anto...@apache.org
Subject svn commit: r106016 - cocoon/trunk/tools/targets
Date Sat, 20 Nov 2004 22:05:42 GMT
Author: antonio
Date: Sat Nov 20 14:05:42 2004
New Revision: 106016

Modified:
   cocoon/trunk/tools/targets/init-build.xml
Log:
Fail if JVM is not 1.4 or superior

Modified: cocoon/trunk/tools/targets/init-build.xml
==============================================================================
--- cocoon/trunk/tools/targets/init-build.xml	(original)
+++ cocoon/trunk/tools/targets/init-build.xml	Sat Nov 20 14:05:42 2004
@@ -29,20 +29,16 @@
     <property file="src/java/org/apache/cocoon/cocoon.properties"/>
 
     <!-- Detecting the current jvm -->
-    <condition property="target.vm" value="1.5">
-      <equals arg1="1.5" arg2="${ant.java.version}"/>
-    </condition>
-    <condition property="target.vm" value="1.4">
-      <equals arg1="1.4" arg2="${ant.java.version}"/>
-    </condition>
-    <condition property="target.vm" value="1.3">
+    <condition property="target.vm" value="${ant.java.version}">
       <not>
         <or>
-          <equals arg1="1.4" arg2="${ant.java.version}"/>
-          <equals arg1="1.5" arg2="${ant.java.version}"/>
+          <equals arg1="1.1" arg2="${ant.java.version}"/>
+          <equals arg1="1.2" arg2="${ant.java.version}"/>
+          <equals arg1="1.3" arg2="${ant.java.version}"/>
         </or>
       </not>
     </condition>
+    <fail unless="target.vm">Please use a JVM 1.4 or superior to compile Cocoon ${version}</fail>
 
     <!-- The location of tools.jar, relative to the JAVA_HOME home. -->
     <property name="tools.jar" value="${java.home}/../lib/tools.jar"/>

Mime
View raw message