cocoon-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stef...@apache.org
Subject cvs commit: cocoon-2.1 blocks.properties
Date Thu, 30 Oct 2003 11:57:07 GMT
stefano     2003/10/30 03:57:07

  Modified:    .        blocks.properties
  Log:
  added missing dependencies of the repository block, excluded xmlform by default from the
build (since deprecated) and moved things around so that dependent blocks are closer together
(also added a little bit of syntax so that people don't miss the dependencies
  
  Revision  Changes    Path
  1.40      +18 -20    cocoon-2.1/blocks.properties
  
  Index: blocks.properties
  ===================================================================
  RCS file: /home/cvs/cocoon-2.1/blocks.properties,v
  retrieving revision 1.39
  retrieving revision 1.40
  diff -u -r1.39 -r1.40
  --- blocks.properties	22 Oct 2003 21:11:19 -0000	1.39
  +++ blocks.properties	30 Oct 2003 11:57:07 -0000	1.40
  @@ -20,15 +20,14 @@
   # developers are committed to back compatibility. In short, stuff that you
   # can depend on.
   
  -#exclude.block.authentication-fw=true
  -
  -#dependency: fop needs batik
  +#exclude.block.fop=true
  +#-----[dependency]: "batik" needed by "fop"
   #exclude.block.batik=true
  -#exclude.block.bsf=true
  -#exclude.block.chaperon=true
  +#-----[dependency]: "databases" needed by "repository"
   #exclude.block.databases=true
  -#exclude.block.fop=true
   #exclude.block.hsqldb=true
  +#exclude.block.bsf=true
  +#exclude.block.chaperon=true
   #exclude.block.html=true
   #exclude.block.itext=true
   #exclude.block.jfor=true
  @@ -42,8 +41,8 @@
   #exclude.block.portal-fw=true
   #exclude.block.profiler=true
   #exclude.block.python=true
  -
  -#dependency: authentication-fw needs session-fw
  +#exclude.block.authentication-fw=true
  +#-----[dependency]: "session-fw" needed by "authentication-fw"
   #exclude.block.session-fw=true
   #exclude.block.swf=true
   #exclude.block.velocity=true
  @@ -64,37 +63,36 @@
   #exclude.block.apples=true
   #exclude.block.asciiart=true
   #exclude.block.axis=true
  -
  -#dependency: scratchpad needs cron
  +#exclude.block.scratchpad=true
  +#-----[dependency]: "cron" needed by "scratchpad"
   #exclude.block.cron=true
   #exclude.block.deli=true
  +#-----[dependency]: "eventcache" needed by "repository"
   #exclude.block.eventcache=true
   exclude.block.jms=true
  +#-----[dependency]: "slide" and "webdav" need "repository"
  +#exclude.block.repository=true
  +#exclude.block.slide=true
  +#exclude.block.webdav=true
   #exclude.block.linotype=true
   #exclude.block.mail=true
   #exclude.block.midi=true
  -# Before including this block, see: http://wiki.cocoondev.org/Wiki.jsp?page=OJBBlock
  -exclude.block.ojb=true
   #exclude.block.petstore=true
   #exclude.block.portal=true
   #exclude.block.precept=true
   #exclude.block.proxy=true
   #exclude.block.qdox=true
  -
  -#dependency: slide, webdav needs repository
  -#exclude.block.repository=true
  -#exclude.block.scratchpad=true
  -#exclude.block.slide=true
   #exclude.block.slop=true
   #exclude.block.stx=true
   #exclude.block.taglib=true
  -#exclude.block.webdav=true
   #exclude.block.woody=true
   
  +# Before including the "ojb" block, see: http://wiki.cocoondev.org/Wiki.jsp?page=OJBBlock
  +exclude.block.ojb=true
   
   # Deprecated blocks ------------------------------------------------------------
   
   # Although some of these blocks may have been stable, they are now deprecated
  -# in favour of other blocks.
  +# in favour of other blocks and therefore are excluded by default from the build
   
  -#exclude.block.xmlform=true
  +exclude.block.xmlform=true
  
  
  

Mime
View raw message