cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Cloudstack - Unable to Upgrade database
Date Fri, 17 Jan 2020 09:24:52 GMT
You have done     yum install mysql-connector-python ?

Which version is installed? (rpm -qa | grep ...)
(I've installed it 4-5 days ago and it was fine)

On Fri, 17 Jan 2020 at 07:57, Cloud Udupi <udupi.cloud@gmail.com> wrote:

> Hi,
>
> I am installing Cloudstack-4.13 on 3 node setup, earlier It used to work
> without any errors. But from 15th of Jan 2020, I'm facing some errors while
> setting up Apache Cloudstack-management server.
>
> *Using this guide:*
>
> http://docs.cloudstack.apache.org/en/latest/quickinstallationguide/qig.html#mysql-connector-installation
>
> Following are the errors;
> *I got this error while running 'cloudstack-setup-management'*
>
> [root@cloud1 ~]# *cloudstack-setup-management*
>
> Traceback (most recent call last):
>
>   File "/usr/bin/cloudstack-setup-management", line 24, in <module>
>
>     from cloudutils.serviceConfigServer import cloudManagementConfig
>
>   File
> "/usr/lib64/python2.7/site-packages/cloudutils/serviceConfigServer.py",
> line 17, in <module>
>
>     from db import Database
>
>   File "/usr/lib64/python2.7/site-packages/cloudutils/db.py", line 20, in
> <module>
>
>     import mysql.connector
>
>   File "/usr/lib64/python2.7/site-packages/mysql/connector/__init__.py",
> line 41, in <module>
>
>     import dns.resolver
>
> ImportError: No module named dns.resolver
>
>
>
> After this I tried Installing python-dns, I was able to run
> "cloudstack-setup-management", but had issue with the dashboard not coming
> up. When I checked the log file, I found the below errors.
>
>
> *Error Message from the Apache CloudStack Management server.*
>
>
> 2020-01-17 11:35:05,275 ERROR [c.c.u.DatabaseUpgradeChecker] (main:null)
> (logid:) Unable to upgrade the database
>
> com.cloud.utils.exception.CloudRuntimeException: Problem with getting the
> ec attribute
>
> Caused by: java.lang.IllegalArgumentException: Can not set long field
> com.cloud.upgrade.dao.VersionVO.id to java.math.BigInteger
>
> at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException
> (UnsafeFieldAccessorImpl.java:167)
>
> at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException
> (UnsafeFieldAccessorImpl.java:171)
>
> 2020-01-17 11:35:05,283 WARN  [o.a.c.s.m.c.ResourceApplicationContext]
> (main:null) (logid:) Exception encountered during context initialization -
> cancelling refresh attempt: org.springframework.context.ApplicationContext
> Exception: Failed to start bean 'cloudStackLifeCycle'; nested exception is
> com.cloud.utils.exception.CloudRuntimeException: Unable to upgrade the
> database
>
> 2020-01-17 11:35:05,285 WARN  [o.e.j.w.WebAppContext] (main:null) (logid:)
> Failed startup of context o.e.j.w.WebAppContext@6e38921c
>
> {/client,file:///usr/share/cloudstack-management/webapp/,UNAVAILABLE}{/usr/share/cloudstack-management/webapp}
>
> org.springframework.context.ApplicationContextException: Failed to start
> bean 'cloudStackLifeCycle'; nested exception is com.cloud.utils.exception
> .CloudRuntimeException: Unable to upgrade the database
>
> Caused by: com.cloud.utils.exception.CloudRuntimeException: Unable to
> upgrade the database
>
> Caused by: com.cloud.utils.exception.CloudRuntimeException: Problem with
> getting the ec attribute
>
> Caused by: java.lang.IllegalArgumentException: Can not set long field
> com.cloud.upgrade.dao.VersionVO.id to java.math.BigInteger
>
> at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException
> (UnsafeFieldAccessorImpl.java:167)
>
> at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException
> (UnsafeFieldAccessorImpl.java:171)
>
>
>
> *This is management status:*
>
>
> [root@cloud1 management]# tail -f management-server.log
>
> at
>
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
>
> ... 61 more
>
> Caused by: java.lang.IllegalArgumentException: Can not set long field
> com.cloud.upgrade.dao.VersionVO.id to java.math.BigInteger
>
> at
>
> sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.java:167)
>
> at
>
> sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.java:171)
>
> at
>
> sun.reflect.UnsafeLongFieldAccessorImpl.set(UnsafeLongFieldAccessorImpl.java:102)
>
> ... 65 more
>
> 2020-01-17 11:35:05,291 INFO  [o.e.j.s.h.ContextHandler] (main:null)
> (logid:) Started o.e.j.s.h.MovedContextHandler@6e2c9341{/,null,AVAILABLE}
>
> 2020-01-17 11:35:05,341 INFO  [o.e.j.s.AbstractConnector] (main:null)
> (logid:) Started ServerConnector@51e2adc7{HTTP/1.1,[http/1.1]}{
> 0.0.0.0:8080}
>
> 2020-01-17 11:35:05,341 INFO  [o.e.j.s.Server] (main:null) (logid:) Started
> @23495ms
>
>
>
> Please help,
>
> Thanks In advance,
>
> Mark.
>


-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message