cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <simon.voel...@zv.fraunhofer.de>
Subject Re: Creating Windows Server 2019 templates with cloudbase init
Date Tue, 14 Jan 2020 18:26:46 GMT
Hi,

Thanks! That’s very helpful.

For resetting the password I had a timing issue, I think. Did you try a reset of the password
and reboot the VM twice? I believe that worked for me during testing.

Regards
Simon

> On 14. Jan 2020, at 19:13, Ismaili, Liridon (SWISS TXT) <Liridon.Ismaili@swisstxt.ch>
wrote:
> 
> Hi,
> @Simon:
> There is a config (found in <https://cloudbase-init.readthedocs.io/en/latest/plugins.html#setting-password-main>
https://cloudbase-init.readthedocs.io/en/latest/plugins.html#setting-password-main) called
first_logon_behavior which you can set to 'no'. This will allow you to setup the password
with no need to be reset after the first login.
> So this one was indeed a cloudbase-init "feature". I did test that and it works fine
for me under MS Windows Server 2019.
> 
> What I get now is, that cloudbase-init allows me to set the password only once - so I
can't reset it after the first launch of the instance. I did create an issue for this one
but I believe that this was by design.
> 
> Regards
> Liridon
> 
> -----Original Message-----
> From: nux@li.nux.ro<mailto:nux@li.nux.ro>
> Reply-To: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
> To: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
> Subject: Re: Creating Windows Server 2019 templates with cloudbase init
> Date: Tue, 14 Jan 2020 13:43:04 +0000
> Mailer: Roundcube Webmail/1.4-rc1
> 
> 
> It's quite possible. I try to do the minimum where Windows is concerned,
> 
> so I stopped at using the old CloudInstanceManager when I saw it's
> 
> working.
> 
> 
> 
> On 2020-01-14 13:28,
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> wrote:
> 
> Hi,
> 
> 
> I believe that having to set a new password after it has been reset is
> 
> supposed to be a feature from Microsoft’s side. I’ve also noticed that
> 
> login through RDP is disabled until a new password has been set. So
> 
> far I haven’t been able to get it to work completely. (mainly due to
> 
> time constraints)
> 
> 
> Regards
> 
> 
> Simon Völker
> 
> 
> Fraunhofer-Gesellschaft e.V.
> 
> Schloss Birlinghoven
> 
> 53754 Sankt Augustin
> 
> Telefon: +49 2241 14-2311
> 
> E-mail:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> 
> 
> 
> Am 14.01.2020 um 14:20 schrieb
> 
> <mailto:nux@li.nux.ro>
> 
> nux@li.nux.ro
> 
> <mailto:
> 
> <mailto:nux@li.nux.ro>
> 
> nux@li.nux.ro
> 
>> :
> 
> 
> Hi,
> 
> 
> This could be a bug (or undocumented feature, ahem) with
> 
> cloudbase-init.
> 
> Despite efforts I never got it to work reliably in the past, not sure
> 
> about now.
> 
> Have you tried using CloudInstanceManager.msi for setting the
> 
> password? It still works for me.
> 
> 
> What I do is set up the template with a sysprep and unattend.xml where
> 
> I also set a default password (perhaps this is what stops it from
> 
> asking for new user pass), then on first boots CloudInstanceManager
> 
> sets up the password without problems and resets work, too. SG zone
> 
> btw.
> 
> 
> Lucian
> 
> 
> On 2020-01-14 12:53, Ismaili, Liridon (SWISS TXT) wrote:
> 
> Hi Simon
> 
> We are also building some new windows templates and would like to use
> 
> cloudbase-init as you do.
> 
> I get the same behavior as you did describe (after password reset it
> 
> requires to setup a new password). How did you workaround this? I
> 
> expect this to be a policy issue but would like to ask before I search
> 
> to long as you had the same issue.
> 
> Regards
> 
> Liridon
> 
> -----Original Message-----
> 
> From:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> Reply-To:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
> <mailto:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
>> <mailto:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
>> 
> 
> To:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
> <mailto:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
>> <mailto:
> 
> <mailto:users@cloudstack.apache.org>
> 
> users@cloudstack.apache.org
> 
>> 
> 
> Subject: Re: Creating Windows Server 2019 templates with cloudbase init
> 
> Date: Mon, 09 Sep 2019 07:54:02 +0000
> 
> Hi,
> 
> we are using cloudplatform 4.11 which is based on cloudstack 4.10.
> 
> Regards
> 
> Simon Völker
> 
> Fraunhofer-Gesellschaft e.V.
> 
> Schloss Birlinghoven
> 
> 53754 Sankt Augustin
> 
> Telefon: +49 2241 14-2311
> 
> E-mail:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> Am 06.09.2019 um 15:34 schrieb Andrija Panic <
> 
> <mailto:
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
>> 
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
>> 
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
> 
> :
> 
> That sounds like something that was happening on ACS 4.8.
> 
> Which version are you running?
> 
> Andrija
> 
> On Fri, 6 Sep 2019 at 14:50, <
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> wrote:
> 
> Hi,
> 
> I’ve checked that and found something peculiar: The password is
> 
> retrieved
> 
> from the VPR if I do a password reset, reboot and reboot again.
> 
> However,
> 
> upon first login with the password generated by the reset, Windows
> 
> requires
> 
> a new password to be set. The password shows up in the passwords file
> 
> on
> 
> the vpr, but isn’t replaced by password=saved, it simply disappears
> 
> when
> 
> retrieved.
> 
> Regards
> 
> Simon Völker
> 
> Fraunhofer-Gesellschaft e.V.
> 
> Schloss Birlinghoven
> 
> 53754 Sankt Augustin
> 
> Telefon: +49 2241 14-2311
> 
> E-mail:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> Am 06.09.2019 um 11:23 schrieb Andrija Panic <
> 
> <mailto:
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
>> 
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
>> 
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
>> 
> 
> <mailto:andrija.panic@gmail.com>
> 
> andrija.panic@gmail.com
> 
> 
> :
> 
> Hi Simon,
> 
> I assume that the cloudbased-init runs BEFORE the user has to set pass
> 
> via
> 
> Windows, thus overwriting the pass that ACS has previously set?
> 
> Does rebooting the VM actually sets the new pass (from ACS), that was
> 
> generated previously? You can actually check inside the VR
> 
> /var/cache/cloud/password-<IP-ADDRESS-HERE> file - this file will
> 
> contain
> 
> the actual pass if it has NOT been fetched by the VM - or if it says
> 
> "password=saved" - this means it was already fetched by the VM.
> 
> Andrija
> 
> On Fri, 6 Sep 2019 at 10:47, <
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> wrote:
> 
> Hi,
> 
> I am currently doing a new batch of our templates. So far we’ve been
> 
> using
> 
> Cloudbase-init for our Microsoft Server 2016 templates. Now with the
> 
> 2019
> 
> version, instead of setting the password that cloudstack provides, the
> 
> user
> 
> has to set a password on first startup. Does someone have experience
> 
> with
> 
> Cloudbase-init and Windows Server 2019 or has faced the same issue?
> 
> Regards
> 
> Simon Völker
> 
> Fraunhofer-Gesellschaft e.V.
> 
> Schloss Birlinghoven
> 
> 53754 Sankt Augustin
> 
> Telefon: +49 2241 14-2311
> 
> E-mail:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> <mailto:
> 
> <mailto:
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
>> 
> 
> <mailto:simon.voelker@zv.fraunhofer.de>
> 
> simon.voelker@zv.fraunhofer.de
> 
> 
> --
> 
> Andrija Panić
> 
> --
> 
> Andrija Panić
Mime
View raw message