cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Very BIG mess with networking
Date Tue, 25 Jun 2019 10:44:19 GMT
I would say, to make sure you have identical network/bond setup as before
(irrelevant of which chils pifs are in the bond/network) - so from
CloudStack point of view, you did zero changes (same networks/bind).

Limited reading capabilities from myside on mobile...but I would say that
pluging in the vif for a guest Network is the problem - in XenServer logs,
you can clearly see error while joining slave interface (vif) to the
network - but again, not sure which network is it (public or guest Network)

On Tue, Jun 25, 2019, 10:50 Alessandro Caviglione <c.alessandro@gmail.com>
wrote:

> No, new bond have the same name...
> In the log there is:
>
>  Found more than one network with the name Public
> 2019-06-25 00:14:35,802 DEBUG [c.c.h.x.r.XsLocalNetwork]
> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) *Found a network called
> Public on host=192.168.200.39;
>  Network=9fa48b75-d68e-feaf-2eb4-8a7340f8c89b;
> pif=ca4c1679-fa36-bc93-37de-28a74ddc4f2c*
> 2019-06-25 00:14:35,807 DEBUG [c.c.h.x.r.CitrixResourceBase]
> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Created a vif
> dfaab3d7-7921-e4d5-ba27-537e8d549a5c on 2
> 2019-06-25 00:14:35,807 DEBUG [c.c.h.x.r.CitrixResourceBase]
> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Creating VIF for r-899-VM on
> nic [Nic:Guest-10.122.12.1-vlan://384]
> 2019-06-25 00:14:35,809 DEBUG [c.c.h.x.r.CitrixResourceBase]
> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Looking for network named
> GuestVM
> 2019-06-25 00:14:35,825 DEBUG [c.c.h.x.r.XsLocalNetwork]
> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Found a network called
> GuestVM on host=192.168.200.39;
>  Network=300e55f0-88ff-a460-e498-e75424bc292a;
> pif=b67841c5-6361-0dbf-a63d-a3e9c1b9f2fc
>
> So it seems that, however, it get the right Network and continue to looking
> for other network.
> Do you think this is the issue also if CS continue with other tasks instead
> stops founding more than one network Public?
> Could I simply change network name in Xen Pool and update in CS?
>
> On Tue, Jun 25, 2019 at 9:52 AM Andrija Panic <andrija.panic@gmail.com>
> wrote:
>
> > If your new bond have changes name, have you changed also XenServer
> Traffic
> > Label in CloudStack ?
> > Active-active is known to be sometimes very problematic, switch back to
> > active-passive until you solve your issues. Experiment later with
> > active-active.
> >
> >
> >
> > On Tue, Jun 25, 2019, 09:34 Michael Kesper <mkesper@schokokeks.org>
> wrote:
> >
> > > Hi Alessandro,
> > >
> > > On 25.06.19 08:43, Alessandro Caviglione wrote:
> > > > complains on more than one network with name Publci...  ???
> > >
> > > [...]
> > >
> > > >> 2019-06-25 00:14:35,792 DEBUG [c.c.h.x.r.CitrixResourceBase]
> > > >> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Looking for network
> > named
> > > >> Public
> > > >> 2019-06-25 00:14:35,793 DEBUG [c.c.h.x.r.CitrixResourceBase]
> > > >> (DirectAgent-35:ctx-c5073156) (logid:0d9e7907) Found more than one
> > > > network
> > > >> with the name Public
> > >
> > > Bye
> > > Michael
> > >
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message