cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Console VM refusing access to console
Date Thu, 27 Jun 2019 19:29:25 GMT
Good that you got it solved.

On Thu, 27 Jun 2019 at 20:42, Fariborz Navidan <mdvlinquest@gmail.com>
wrote:

> Thanks. The issue was firewall rules After rebot I needed to restore rules
>
> Thanks
>
> On Thu, Jun 27, 2019 at 10:49 PM Andrija Panic <andrija.panic@gmail.com>
> wrote:
>
> > Well...
> >
> > I would suggest opening Developer Tools in the browser, and observe the
> > iframe URL - it is loading an HTTP/HTTPS URL from the Public IP of the
> CPVM
> > (you can see it there as iframe URL, or on the CPVM itself).
> >
> > 1. Copy that URL of the iframe, and enter in into new tab address field
> and
> > see if that works (probably not).
> >
> > 2. Next, try to telnet to the public IP of the CPVM on port 80/443
> > (depending if you use SSL certificate for CPVM) - make sure that works
> > (from your laptop) - if it doesn't than CPVM is in some problem - login
> > inside it and check if public IP present) - in general I expect that your
> > CPVM is all happy in green (VM state= Running and Agent State = UP ???)
> >
> > 3. If the previous step is working, then you can access CPVM just fine,
> but
> > the CPVM itself can't access the hypervisor - there I would make sure
> that
> > firewall have not resurrected and that all network config is in place
> >
> > Let us know how it goes.
> >
> > Andrija
> >
> > On Thu, 27 Jun 2019 at 19:55, Fariborz Navidan <mdvlinquest@gmail.com>
> > wrote:
> >
> > > Hello,
> > >
> > > I did but issue exists.
> > >
> > > Please advise.
> > >
> > > Thanks
> > >
> > > On Thu, Jun 27, 2019 at 9:47 PM Andrija Panic <andrija.panic@gmail.com
> >
> > > wrote:
> > >
> > > > destroy CPVM, it will be recreated
> > > >
> > > >
> > > > On Thu, 27 Jun 2019 at 18:46, Fariborz Navidan <
> mdvlinquest@gmail.com>
> > > > wrote:
> > > >
> > > > > Hello,
> > > > >
> > > > > After recent reboot, console proxy refuses access to all VMs with
> > error
> > > > > Unable
> > > > > to start console session as connection is refused by the machine
> you
> > > are
> > > > > accessing
> > > > >
> > > > > Please advise.
> > > > >
> > > > > Thanks
> > > > >
> > > >
> > > >
> > > > --
> > > >
> > > > Andrija Panić
> > > >
> > >
> >
> >
> > --
> >
> > Andrija Panić
> >
>


-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message