cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Pretorious <pdxpi....@gmail.com>
Subject Re: Cloudstack 4.11.2.0, Maven Error: testIsMockServerCanUpgradeConnectionToSsl (javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure)
Date Tue, 04 Jun 2019 04:08:07 GMT
> perhaps you are hitting the same issues - i.e. *try to keep  your jdk
lower version than this.*

Thanks, Andrija - *But I'm not sure what that means!* (i.e., I know nothing
about Java!)

I did *however* go in search of the setting - and I found it! But the
setting is in a binary format:

root@cloudstack:~ # grep -ri SSL_NULL_WITH_NULL
/usr/lib/jvm/java-8-openjdk-amd64/*
Binary file /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jsse.jar matches


root@cloudstack:~ # strings
/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/jsse.jar | grep SSL_NULL
SSL_NULL_WITH_NULL_NULL

So I've run into another wall it seems!

Thanks, again! I'm going to investigate skipping that unit test *as Rohit
suggested* and see if that yields and better results.

Eric Pretorious
Portland, Oregon

On Mon, Jun 3, 2019 at 12:27 AM Andrija Panic <andrija.panic@gmail.com>
wrote:

> Hi Eric,
>
> please check email thread on DEV ml, from Rohit, titled "Master breaking
> with jdk 1.8.0_201+" from 13th May I believe  - perhaps you are hitting the
> same issues - i.e. try to keep  your jdk lower version than this.
>
> "I've found the issue to be specific to newer JDK versions that disable
> SSL_NULL_WITH_NULL by default."
>
> Let me know if that helps,
>
> Andrija
>
>
> On Mon, 3 Jun 2019 at 06:42, Eric Pretorious <pdxpi.org@gmail.com> wrote:
>
> > I am attempting to build Cloudstack 4.11.2.0 on Ubuntu-18.04 [Bionic
> > Beaver] - *This time an Intel Core2 Duo (x86_64)*...
> >
> > root@cloudstack:~# lsb_release -a
> > No LSB modules are available.
> > Distributor ID: Ubuntu
> > Description:    Ubuntu 18.04.2 LTS
> > Release:        18.04
> > Codename:       bionic
> >
> >
> > ...using the instructions that are available on the Apache Cloudstack
> > Documentation page
> > <
> >
> http://docs.cloudstack.apache.org/en/latest/installguide/building_from_source.html
> > >.
> > But when I get to the "Building DEB packages" section and I execute the
> > command...
> >
> > root@cloudstack:/usr/local/src/apache-cloudstack-4.11.2.0-src# mvn -P
> deps
> >
> >
> > ...the command fails (after 10 minutes of execution time). I found this
> > test report:
> >
> > root@cloudstack:
> > cat
> >
> /usr/local/src/apache-cloudstack-4.11.2.0-src/services/console-proxy-rdp/rdpconsole/target/surefire-reports/rdpclient.MockServerTest.txt
> >
> >
> >
> >
> -------------------------------------------------------------------------------
> > Test set: rdpclient.MockServerTest
> >
> >
> -------------------------------------------------------------------------------
> > Tests run: 2, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.463 sec
> > <<< FAILURE! - in rdpclient.MockServerTest
> > testIsMockServerCanUpgradeConnectionToSsl(rdpclient.MockServerTest)  Time
> > elapsed: 0.443 sec  <<< ERROR!
> > javax.net.ssl.SSLHandshakeException: Received fatal alert:
> > handshake_failure
> >         at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
> >         at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
> >         at
> > sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:2020)
> >         at
> > sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1127)
> >         at
> >
> >
> sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1367)
> >         at
> > sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1395)
> >         at
> > sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1379)
> >         at
> >
> >
> rdpclient.MockServerTest.testIsMockServerCanUpgradeConnectionToSsl(MockServerTest.java:163)
> >
> >
> > So I searched the Interwebs and found these instructions
> > <
> >
> https://stackoverflow.com/questions/38203971/javax-net-ssl-sslhandshakeexception-received-fatal-alert-handshake-failure/38264878
> > >
> > and these instructions
> > <
> >
> https://stackoverflow.com/questions/41971549/cant-connect-to-eclipse-marketplace
> > >
> > on Stackoverflow. Both were the same:
> >
> > 3. Download the Java Cryptography Extension from Oracle:
> >
> >    - Java7:
> >
> >
> http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html
> >    - Java8:
> >
> >
> http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
> >
> > And unzip it.
> > 4. / Copy local_policy.jar and US_export_policy.jar just just downloaded
> > into the JRE's .../lib/security sub-folder
> >
> >  ...so I downloaded the Java Cryptography Extension (JCE) .jar
> > <
> >
> https://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
> > >
> > from Oracle.com and installed it per the instructions:
> >
> > root@cloudstack:/usr/local/src# pwd
> > /usr/local/src
> >
> > root@cloudstack:/usr/local/src# unzip jce_policy-8.zip
> > Archive:  jce_policy-8.zip
> >    creating: UnlimitedJCEPolicyJDK8/
> >   inflating: *UnlimitedJCEPolicyJDK8/local_policy.jar*
> >   inflating: UnlimitedJCEPolicyJDK8/README.txt
> >   inflating: *UnlimitedJCEPolicyJDK8/US_export_policy.jar*
> >
> > root@cloudstack:/usr/local/src# mv UnlimitedJCEPolicyJDK8/*.jar
> > /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/security/
> >
> > root@cloudstack:/usr/local/src# ll
> > /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/security/
> >
> > lrwxrwxrwx 1 root root   46 Apr 26 01:04 blacklisted.certs ->
> > /etc/java-8-openjdk/security/blacklisted.certs
> > lrwxrwxrwx 1 root root   27 Apr 26 01:04 cacerts ->
> > /etc/ssl/certs/java/cacerts
> > lrwxrwxrwx 1 root root   40 Apr 26 01:04 java.policy ->
> > /etc/java-8-openjdk/security/java.policy
> > lrwxrwxrwx 1 root root   42 Apr 26 01:04 java.security ->
> > /etc/java-8-openjdk/security/java.security
> > -rw-rw-r-- 1 root root 3035 Dec 20  2013 *local_policy.jar*
> > lrwxrwxrwx 1 root root   36 Apr 26 01:04 nss.cfg ->
> > /etc/java-8-openjdk/security/nss.cfg
> > drwxr-xr-x 4 root root 4096 May 29 04:14 policy/
> > -rw-rw-r-- 1 root root 3023 Dec 20  2013 *US_export_policy.jar*
> >
> >
> > And then I re-ran the command...
> >
> > root@cloudstack:/usr/local/src/apache-cloudstack-4.11.2.0-src# mvn -P
> deps
> >
> >
> >
> > *But I still receive the same error!*
> >
> > What do I need to do to fix this error and complete the build process for
> > Apache Cloudstack 4.11.2.0?
> >
> > Eric Pretorious
> > Portland, Oregon
> >
>
>
> --
>
> Andrija Panić
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message