cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@shapeblue.com>
Subject RE: cloudstack usage server issue
Date Thu, 07 Mar 2019 11:23:34 GMT
Hi Konstantin,

Can you please usage upload the logs to somewhere (pastebin is OK) so we can check ?

Did you/can you try with 4.11.2 ?
 
Kind regards,
Andrija

andrija.panic@shapeblue.comĀ 
www.shapeblue.com
Amadeus House, Floral Street, London  WC2E 9DPUK
@shapeblue
  
 


-----Original Message-----
From: Konstantin <konstantin.kirsanov@gmail.com> 
Sent: 06 March 2019 23:20
To: users@cloudstack.apache.org
Subject: cloudstack usage server issue

 I did installed the management server, connect it to ESX HV, the control part working fine.

I deployed the usage server with all guidelines awareness but have no luck with processing
a usage data from "cloud" DB to "cloud_usage" DB by usage server.

I tried to configure, reconfigure and even reinstall everything, but the last usage server
log record is always same:

2019-03-06 18:21:28,903 DEBUG [cloud.usage.UsageManagerImpl] (main:null)
(logid:) Checking to see if usage.vmops.pid exists.
2019-03-06 18:21:28,903 INFO  [cloud.usage.UsageManagerImpl] (main:null)
(logid:) Implementation Version is 4.12.0.0
2019-03-06 18:21:30,865 DEBUG [cloud.usage.UsageManagerImpl] (main:null)
(logid:) Usage stats aggregation time zone: UTC
2019-03-06 18:21:30,866 DEBUG [cloud.usage.UsageManagerImpl] (main:null)
(logid:) Execution Time: Wed Mar 06 18:22:00 UTC 2019
2019-03-06 18:21:30,866 DEBUG [cloud.usage.UsageManagerImpl] (main:null)
(logid:) Current Time: Wed Mar 06 18:21:30 UTC 2019
2019-03-06 18:21:30,874 INFO  [cloud.usage.UsageServer] (main:null)
(logid:) UsageServer ready...

As you may see, I played with starting time to force usage server to start the job, but no
luck...
Its never gave me any logs written and any action taken after " UsageServer ready... "
I tried to call

[root@cloudstack usage]# cloudmonkey generateUsageRecords
startdate=2018-09-01 enddate=2019-09-30
success = True

but the "cloud_usage" DB is always empty, the all tables are empty, no single line in it.
In the same time, the "cloud" DB and usage_event table is full of data with prossessed column
"0" for any record in the table.

Do you know how to force usage server to start the job?

here is my usage params info:

enable.usage.server    true
publish.usage.events    true
quota.usage.smtp.connection.timeout    60
quota.usage.smtp.host
quota.usage.smtp.password
quota.usage.smtp.port
quota.usage.smtp.sender
quota.usage.smtp.useAuth
quota.usage.smtp.user
usage.aggregation.timezone    UTC
usage.execution.timezone    UTC
usage.sanity.check.interval    1
usage.snapshot.virtualsize.select    false
usage.stats.job.aggregation.range    5 //I changed it from 5 to 60 and 1440
with same negative result
usage.stats.job.exec.time    18:22 /changed many times to fire job, no luck


Regards,
Konstantin
Mime
View raw message