cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vivek Singh" <vive...@cyborgsys.net>
Subject RE: Storage VM not getting start new setup
Date Fri, 28 Dec 2018 07:42:13 GMT
Hello Andrija,

Thanks for the quick response.
Here is detail:
1. I tried with latest version give in the link you shared  https://github.com/apache/cloudstack-documentation/blob/master/source/quickinstallationguide/qig.rst.
 But same result All my installation endup with same result. I mean with error   "There is
no secondary storage VM for secondary storage host nfs". Even With disabled firewall as well.
 

2.  when you says "KVM traffic label"  I think you are telling to use bridge cloudbr0 .I am
using the same as you can see in the attached outputs. I didn't see any green/red/blue/yellow
nice buttons in GUI interface.
      Can you please guide me where I can find those?
3. You said don't reboot SVM  manually. I agree but I can't find any other way to find what
is going on. It is not accessible through console view in gui. Neither using this command
"ssh -i    /var/cloudstack/management/.ssh/id_rsa  -p 3922 root@169.254.3.222". However I
can see the ip address assigned on gui  of cloudstackt manager.

Please find attached all the detail you are looking for.  Let me know if needed further information.

Centos6 is with old setup and Centos7 with the link you shared . Remember only one server
was up a time.

Regards
Vivek



         

-----Original Message-----
From: Andrija Panic [mailto:andrija.panic@gmail.com] 
Sent: 27 December 2018 15:11
To: users <users@cloudstack.apache.org>
Subject: Re: Storage VM not getting start new setup

Hi Vivek,

FYI: Please note that CentOS 6 is depreciated in latest CloudStack version
- perhaps better to try with latest versions of Centos and CloudStack as noted here:
https://github.com/apache/cloudstack-documentation/blob/master/source/quickinstallationguide/qig.rst
- this a fresh guide, tested properly on Centos 7.5 and CLoudStack 4.11.2

But down to your problem...

Based on your input there are 2 VMs started - but not fully "patched" to become CPVM and SSVM.

Don't ever manually reboot VMs since they are not meant to be rebooted - it will boot broken
with i.e. no network config inside etc.
Just use the "Destroy" button on both CPVM and SSVM  and they will be re-generated again brand
new. After VMs are initially created, there will be special ISO attached to them to "patch"
them properly and these vanila VMs will be configured as needed (with custom scripts and info
from DB), including IP settings etc...
It takes some time to bring up the VMs, so please be patient.

I would also stronglu suggest, during troubleshooting, to disable firewall completely on KVM
host - later you can play with it - and it can sometimes be a problem - so safer to disable
during installation.

Can you share your network setup on KVM host , and zone netwrok setup, hypervisor used, etc
? If you are following quick guide, I assume KVM on CentOS 6..
Name of your bridge should be set as the "KVM traffic label" for each traffic type (Management,
Guest,Storage etc) - when you click on these green/red/blue/yellow nice buttons, you can set
"KVM traffic label" - this should be the name of your bridge that you previously created on
KVM host.

Another things to mention - after CPVM and SSVM are started fine - you can use Console access
to SSVM and login with root/password, and then test SSVM
operations by running script:      /usr/local/cloud/systemvm/ssvm-check.sh
This script will check if SSVM can access internet, if DNS resolution works, if it can mount
Secondary Storage to itself, and if it can connect it's Agent to the Management Server.

Cheers
Andrija




On Thu, 27 Dec 2018 at 12:22, Vivek Singh <vivek.s@cyborgsys.net> wrote:

> Hello Friends,
>
>
>
> I am new to cloudstack and from last 2 weeks I am struggling to 
> install  cloudstack using  quick installation procedure ( 
> http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/
> 4.9/qig.html
> ).
>
> I tried all the method that I can google and apply but no luck.
>
>
>
>
>
> I am using  VM on ESXi  as a management server. I enable promiscuous 
> mode on ESXi switch. I am using Centos6.10
>
>
>
> My ssvm and cosole-proxy VM are not coming up. I'm login through 
> virt-manager  into both system vm and found their network cards are not up.
>
> I assign static ip and rebooted but all the ip deleted from interfaces 
> after reboot.
>
>
>
> I am attaching log when I started the installation utill I getting the 
> error message “There is no secondary storage VM for secondary storage host”.
>
>
>
>
>
> I really appreciate any help
>
>
>
>
>
>
>
> *Vivek Singh *
>
>
>


-- 

Andrija Panić

Mime
View raw message