cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Bouige <>
Subject RE: ssvm NFS public ip
Date Thu, 12 Apr 2018 07:56:12 GMT
Hi Paul,

I used repository from shapeblue for mgmt-server and systemvm-template.
Im going to make a new fresh install (again :/) and double check the URL.


Best regards,

-----Message d'origine-----
De : Paul Angus [] 
Envoyé : jeudi 12 avril 2018 09:12
À :
Objet : RE: ssvm NFS public ip

Hi Nicolas, this usually happens if you mix redist and noredist builds of mgmt. server and
system vm code.

What URLs did you use for the management server repo and the system VM templates?
53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue

-----Original Message-----
From: Nicolas Bouige <>
Sent: 11 April 2018 19:44
Subject: RE: ssvm NFS public ip

Hi ilya,

Thanks for your answer

Yes i did it already with no effect :/

Best regards,


De : ilya musayev <> Envoyé : mercredi 11 avril 2018 20:26:34
À : Objet : Re: ssvm NFS public ip

There is a global setting you have to set to use internal non public IP.

Try setting to an internal network cidr.

You may need to destroy ssvm for settings to take effect. In my case there is some sort of
minor bug where it takes upward of 5 minutes for ssvm to program the internal routes, but
since this is onetime operation - I just live with it.

On Wed, Apr 11, 2018 at 10:50 AM Nicolas Bouige <> wrote:

> a small update about my problem.
> I 've recreated the zone from scratch this morning and  one of my 
> "cloudbr" used for the secondary storage was misconfigured.
> So Now, I can ping the secondary storage from KVM host, CS-MGMT,  SSVM 
> and mount the nfs on them...but...the agent still not going up and the 
> give me an ip public for the nfs instead of the private.
> i got only this error in /var/log:cloud.log :
> 17:30:22,600 ERROR AgentShell:477 - Unable to start agent: Resource 
> class not found: due
> to: java.lan                            g.ClassNotFoundException:
>       urce
> Unable to start agent: Resource class not found:
> iumSecondaryStorageResource due to: java.lang.ClassNotFoundException:
> storage.resource.PremiumSecondaryStorageResource
> i've tried to update a differente systemvm template with no success...
> I 've compared the configuration of the ssvm with one of our 
> deployment and i juste noticed the "resource"
> ( was not 
> the same.
> i changed it but still the same error...
> There is a way to find java binaries/script and  upload them on the ssvm ?
> If one of you have an idea, it would be appreciate.
> Thanks !
> Best regards,
> N.B

View raw message