cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swastik Mittal <mittal.swas...@gmail.com>
Subject Re: iso not downloading from local path
Date Wed, 07 Feb 2018 06:36:21 GMT
I checked my cloud.log in my SSVM. After the URL request it mentions

[storage.template.HttpTemplateDownloader] (agentRequest-Handler-3:null) No
credentials configured for host <local file server ip>

On Wed, Feb 7, 2018 at 11:32 AM, Swastik Mittal <mittal.swastik@gmail.com>
wrote:

> Hey,
>
> I do not have internet on management server and host so to upload an iso I
> set secstorage.allowed.internal.sites to my CIDR. I used
>
> $ python -m SimpleHTTPServer 443
>
> to host my directory on http server where I had kept my downloaded iso. By
> manually visiting the local http server I am able to download the file. But
> on mentioning the same url in registering the iso it shows registered
> successfully but does not get downloaded.
>
> In the zone section in the iso it mentions not ready. I receive a broken
> pipe error at the initial stage in my local file server log but then it
> again shows processing request. Even the iso status in management shows
> nothing and when I stop the local file server the status of iso shows 0%
> downloaded and then partial get request cannot be served. I believe
> management server keeps on pinging the local file server but the connection
> is not getting established.
>
> I even refreshed my server again and again and also did wait for a long
> enough time to see if the process is slow. logging into system VM and
> running ./run.sh does not show any error and cloud services are running
> fine. I am pretty sure about the CIDR I have mentioned in
> secstorage.allowed.internal.sites. Any idea?
>
> Regards
> Swastik
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message