cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessandro Caviglione <c.alessan...@gmail.com>
Subject Manually copy volume and update database
Date Fri, 08 Dec 2017 18:10:05 GMT
Hi guys,
I've a little issue.
We're decommissioning a XS6.2 cluster and the last instance is a big one,
with a DATA DISK of 1 TB.
Our cluster is connected by NFS and we're trying to migrate this instance
to a new XS6.5 cluster but every try, will fail.
I tried to shutdown the instance and move the disk with API: migrate volume
volumeid=8d5d0640-49cd-40e2-8318-f6732ce91094
storageid=c24cd510-10ff-3cf2-b490-76bc4028d81e

but after some hours I got:
Error
Async job 741bffa2-ef32-4f3d-b013-f66e0c1c4836 failed
Error 530, Resource [StoragePool:14] is unreachable: Migrate volume failed:
com.cloud.utils.exception.CloudRuntimeException: Failed to migrate volume
org.apache.cloudstack.storage.volume.VolumeObject@73f6327b to storage pool
org.apache.cloudstack.storage.datastore.PrimaryDataStoreImpl@286c64b7


Since the new cluster uses the same storage, I can just copy/past the VHD
directly on the storage and change the database data to let the instance
point to the new VHD just copied.
I've already tried to do this changing these tables:
volumes: pool_id, last_pool_id, folder,
vm_instance: last_host_id, power_host


But the instance does not start...

Any suggestion??

Thank you!!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message