cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Liivak <k...@wavecom.ee>
Subject Re: set password with instance creation
Date Mon, 13 Nov 2017 19:07:49 GMT

Thanks for suggestion, Dag
Im confident. I have made several sets of tests. 
I noticed issue allready with my previous install ACS 4.9 and systemvms 4.6
But it was not first in my todo list.

I have created issue in jira https://issues.apache.org/jira/browse/CLOUDSTACK-10141


Lugupidamisega / Regards

Kristian Liivak
CTO
   
WaveCom As
Kotka 26,Tallinn 
Estonia
http://www.wavecom.ee

----- Original Message -----
From: "Dag Sonstebo" <Dag.Sonstebo@shapeblue.com>
To: "users" <users@cloudstack.apache.org>
Sent: Monday, November 13, 2017 5:30:29 PM
Subject: Re: set password with instance creation

Hi Kristian,

Sounds like there may be issues with the initial password configuration. If you’re confident
in your testing maybe log a Jira ticket for this.

With regards to passwords being reset back to a previous one – we came across this recently
(see https://issues.apache.org/jira/browse/CLOUDSTACK-10113 ) and wrote a patch – will find
out more info and update this thread. Please note the patch did not fix any initial password
set issues though.

Regards,
Dag Sonstebo
Cloud Architect
ShapeBlue

On 13/11/2017, 15:06, "Kristian Liivak" <kris@wavecom.ee> wrote:

    Hi all
    
    I performed several tests with macchinina template. 
    before that i restarted network with clean up option eg new VR was created.
    
    But result are: VR password file is not modified after instance creation. 
    Even file is not created when i first time created instance.
    Shutdown instance and reset password only created VR password file and it contains correct
entry then
    And finally next try with new instance brings back 1st instance password enrty to VR 
password file wich is not correct i guess also ?
    
    My log is here:; ips are changed with aaa.bbb.ccc
    I have only one network present. its one big /24 shared network for all vms. Also ipv6
is present
    cloudmonkey list network output is also added below.
    
    Thanks forward if someone is helping to clarify my issue.
    
    
    Restarted netowrk with option cleanup. logged in to VR
    root@r-377-VM:/var/cache/cloud# ls -lah
    total 36K
    drwxr-xr-x  3 root root 4.0K Nov 13 14:35 .
    drwxr-xr-x 10 root root 4.0K Nov 13 14:29 ..
    -rw-r--r--  1 root root   29 Nov 13 14:29 boot_up_done
    -rw-r--r--  1 root root   33 Nov 13 14:28 cloud-scripts-signature
    -rw-r--r--  1 root root  754 Nov 13 14:29 cmdline
    -rw-r--r--  1 root root   33 Nov 13 14:29 disabled_svcs
    -rw-r--r--  1 root root    2 Nov 13 14:29 dnsmasq_managed_lease
    -rw-r--r--  1 root root   38 Nov 13 14:29 enabled_svcs
    drwxr-xr-x  2 root root 4.0K Nov 13 14:35 processed
    
    Created new instance and get gui password "Password of new VM Macchinina1 is EJ4cQ2"
    Nothing changed in files /var/cache/cloud
    
    shutdown instance and reset succesfully  password in gui"Password has been reset to dt8sNZ"
    Now i have correct file created in VR and it contains correct password
    
    root@r-377-VM:/var/cache/cloud# ls -lah
    total 40K
    drwxr-xr-x  3 root root 4.0K Nov 13 14:37 .
    drwxr-xr-x 10 root root 4.0K Nov 13 14:29 ..
    -rw-r--r--  1 root root   29 Nov 13 14:29 boot_up_done
    -rw-r--r--  1 root root   33 Nov 13 14:28 cloud-scripts-signature
    -rw-r--r--  1 root root  754 Nov 13 14:29 cmdline
    -rw-r--r--  1 root root   33 Nov 13 14:29 disabled_svcs
    -rw-r--r--  1 root root    2 Nov 13 14:29 dnsmasq_managed_lease
    -rw-r--r--  1 root root   38 Nov 13 14:29 enabled_svcs
    -rw-r--r--  1 root root   21 Nov 13 14:37 passwords-aaa.bbb.ccc.2
    drwxr-xr-x  2 root root 4.0K Nov 13 14:37 processed
    root@r-377-VM:/var/cache/cloud# more passwords-aaa.bbb.ccc.2
    aaa.bbb.ccc.196=dt8sNZ
    
    powered up instance and tailed VR  password file
    
    root@r-377-VM:/var/cache/cloud# tail -f passwords-aaa.bbb.ccc.2
    aaa.bbb.ccc.196=dt8sNZ
    tail: passwords-aaa.bbb.ccc.2: file truncated
    
    Vm have correct password. And VR password file is empty
    
    Next try with new instance. created. Password of new VM Macchinina2 is U8jBqC,,  tailed
VR password file. No changes at all..
    
    stopped new instance. resetted password "Password has been reset to Y9mwzN"
    
    
    root@r-377-VM:/var/cache/cloud# tail -f passwords-aaa.bbb.ccc.2
    aaa.bbb.ccc.196=dt8sNZ
    aaa.bbb.ccc.169=Y9mwzN
    
    new password is there.
    But now i have old instance password there again however it was gone before ??
    
    tail: passwords-aaa.bbb.ccc.2: file truncated
    aaa.bbb.ccc.196=dt8sNZ
    
    Vm started. password is changed . VR password file enrty is removed howerver my 1st instance
password is still there ?
    
    
    
    
    
    Cloudmonkey
    
    (local) 🐵 > list networks
    count = 1
    network:
    id = 8bb0f3fa-d985-4940-834d-df00b166e01d
    name = guest1
    acltype = Domain
    broadcastdomaintype = Vlan
    broadcasturi = vlan://17
    canusefordeploy = True
    cidr = aaa.bbb.ccc.0/24
    displaynetwork = True
    displaytext = guest1
    dns1 = 80.79.112.2
    dns2 = 80.79.112.20
    domain = ROOT
    domainid = a3356c86-df35-11e6-9018-005056a00a77
    gateway = aaa.bbb.ccc.1
    ip6cidr = 2a01:97a0:0:7::/64
    ip6gateway = 2a01:97a0:0:7::1
    ispersistent = False
    issystem = False
    netmask = 255.255.255.0
    networkdomain = wavecom.ee
    networkofferingavailability = Optional
    networkofferingconservemode = True
    networkofferingdisplaytext = Offering for Shared networks
    networkofferingid = 601de2c9-c1e3-47a8-a08c-79896be9469f
    networkofferingname = DefaultSharedNetworkOffering
    physicalnetworkid = 53bcca6d-3569-4541-b4e4-20116d77e373
    related = 8bb0f3fa-d985-4940-834d-df00b166e01d
    restartrequired = True
    service:
    name = Dhcp
    capability:
    name = DhcpAccrossMultipleSubnets
    canchooseservicecapability = False
    value = true
    ================================================================================
    name = UserData
    ================================================================================
    name = Dns
    capability:
    name = AllowDnsSuffixModification
    canchooseservicecapability = False
    value = true
    specifyipranges = True
    state = Setup
    strechedl2subnet = False
    subdomainaccess = True
    tags:
    traffictype = Guest
    type = Shared
    vlan = 17
    zoneid = fd1a23f1-49a8-445f-8ef7-caa1a7af1b4d
    zonename = zone1
    
    
    
    Lugupidamisega / Regards
     
    Kristian Liivak
    CTO
    
    WaveCom As
    Kotka 26, 11312 Tallinn Estonia
    http://www.wavecom.ee
    
    
    
Dag.Sonstebo@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 

----- Original Message -----
    From: "Pierre-Luc Dion" <pdion@cloudops.com>
    To: "users" <users@cloudstack.apache.org>
    Sent: Monday, November 13, 2017 3:03:56 PM
    Subject: Re: set password with instance creation
    
    Hi Kristian,
    
    Have you tried cloud-init with is configurations for cloudstack?
    
    
    
    Le 13 nov. 2017 06 h 21, "Dag Sonstebo" <Dag.Sonstebo@shapeblue.com> a
    écrit :
    
    Hi Kristian,
    
    First thing to work out is whether this is down to your template or ACS.
    Could you try downloading the Macchinina template and see if this works?
    
    http://dl.openvm.eu/cloudstack/macchinina/
    
    If Macchinina does work then likelihood is something with your service
    configuration isn’t quite right.
    
    Regards,
    Dag Sonstebo
    Cloud Architect
    ShapeBlue
    
    On 11/11/2017, 17:46, "Kristian Liivak" <kris@wavecom.ee> wrote:
    
        Hi there
    
        I´m struggeling with template set password script. It won´t set
    password with instance creation.
    
        In template logs i can see..
        Nov 11 19:32:59 localhost cloud: Got response from server
        Nov 11 19:32:59 localhost cloud: VM has already saved a password from
    the password server at
    
        With manual try with wget
        ;;
        [root@centostest2 log]# wget -q -t 3 -T 20 -O - --header "DomU_Request:
    send_my_password" xx.x.xx.x.x:8080
        saved_password
    
        However password is set properly next time after i shutdown instance
    and choose set password.
    
        Is there any limitation/configuration/bug what im missing with instance
    creation ?
    
        Im using ver 4.10 and template is centos 7
    
        Any advice or hint is most appreciated.
    
        Regards,
    
        Kristian Liivak
        CTO
        WaveCom As
        Kotka 26, 11312 Tallinn
        http://www.wavecom.ee
    
    
    
    
    Dag.Sonstebo@shapeblue.com
    www.shapeblue.com
    53 Chandos Place, Covent Garden, London  WC2N 4HSUK
    @shapeblue

Mime
View raw message