cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sateesh Chodapuneedi <sateesh.chodapune...@accelerite.com>
Subject Re: Configuring CS with Advance Networking for an internal laboratory
Date Fri, 08 Sep 2017 13:42:16 GMT
Hi Luis,
I have configured Cisco 3750G switch for my CloudStack advanced mode setup. Configuration
should be the similar for Cisco 3560 as well, probably might help you.

>> 4 Nics: 2 for Management-Storage (LACP) and 2 for Public-Guest
Make sure to setup the VLANs before configuring the switch ports for interfaces meant for
Public and Guest traffic
conf t
vlan <PUBLIC_VLAN_RANGE>,<ZONE_VLAN_RANGE>
end
Please note that the VLAN range meant for public traffic are routable (with subnet assigned)
Configure the switch ports for Public and Guest traffic
switchport mode trunk
switchport trunk encapsulation dot1q 
switchport trunk allowed vlan <PUBLIC_VLAN_RANGE>,<ZONE_VLAN_RANGE> 
Ex: If 100 is VLAN ID of routable VLAN meant for public traffic, and VLAN IDs 500 to 600 are
guest (zone) VLANs, then above command looks like,
switchport trunk allowed vlan 100,500-600

Regards,
Sateesh Chodapuneedi,
CloudStack Development,
Engineering, http://accelerite.com
Santa Clara, 95054, CA
@accelerite

-----Original Message-----
From: Luis <lmartinez073@yahoo.com.INVALID>
Reply-To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>, Luis <lmartinez073@yahoo.com>
Date: Friday, 8 September 2017 at 5:39 PM
To: Paul Angus <paul.angus@shapeblue.com>, "users@cloudstack.apache.org" <users@cloudstack.apache.org>
Subject: Re: Configuring CS with Advance Networking for an internal laboratory

    Thank you Paul
    Your article is really helpful, I think my problem is finding the correct commands to
setup the switch, this is what I have
    CS 4.10: on Ubuntu 14.044 nics: 2 for management (LACP) and 2 for Storage (LACP)
    XenServer for host4 Nics: 2 for Management-Storage (LACP) and 2 for Public-Guest
    Is it possible for you or the group to help me with the lines to set up correctly  the
Cisco Switch, I will appreciate your help
    Cisco Switch 3560Ports: 9 - 10 for Management-storageconf tinterface range Gi0/9 - 10switchport
mode accessno shutchannel-group 3 mode activechannel-protocol lacpend
    Port 11 - 12 for Piblic-Guest
    conf tinterface range Gi0/11 - 12switchport mode accessno shutchannel-group 4 mode activechannel-protocol
lacpend      From: Paul Angus <paul.angus@shapeblue.com>
     To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>; Luis <lmartinez073@yahoo.com>

     Sent: Friday, September 8, 2017 5:19 AM
     Subject: RE: Configuring CS with Advance Networking for an internal laboratory
       
    Luis,
    
    You may find this blog from yester-year helpful:
    
    http://www.shapeblue.com/understanding-cloudstacks-physical-networking-architecture/
    
    
    Kind regards,
    
    Paul Angus
    
    paul.angus@shapeblue.com 
    www.shapeblue.com
    53 Chandos Place, Covent Garden, London  WC2N 4HSUK
    @shapeblue
      
     
    
    
    -----Original Message-----
    From: Paul Angus [mailto:paul.angus@shapeblue.com] 
    Sent: 07 September 2017 22:12
    To: Luis <lmartinez073@yahoo.com>; users@cloudstack.apache.org
    Subject: RE: Configuring CS with Advance Networking for an internal laboratory
    
    No problem Luis,
    
    
      1.  Advanced networking replies on VLANs (or some SDN isolation method), so you need
at have a range of VLANs free, that you tell CloudStack that it can use.
      2.  The IP ranges I described were only an example you can you any range you like, but
‘public’ traffic generally is going to require a gateway in order to ‘go’ somewhere.
      3.  I looks to me like you are setting all of your interfaces as access ports. You’ll
need ports which deal with multiple VLANs (like ones used for guest networks) to be trunk
ports – with the VLANs which are allowed matching those that you have told CloudStack that
it can use.
    
    
    Kind regards,
    
    Paul Angus
    
    
    paul.angus@shapeblue.com
    www.shapeblue.com
    53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue
      
     
    
    From: Luis [mailto:lmartinez073@yahoo.com]
    Sent: 07 September 2017 20:32
    To: Paul Angus <paul.angus@shapeblue.com>; users@cloudstack.apache.org
    Subject: Re: Configuring CS with Advance Networking for an internal laboratory
    
    thank you for your help, I have some questions if you can help me to answer this
    
    1.- can i not use VLAN's for Advance Networking or are necessary for the configuration
    
    2.- Do I need to create an extra server ans use it as gateway for this range of IP's?
    
    3.- this is what I am using to create my vlan's on a Cisco 3560, is this correct?
    conf t
    interface range Gi0/9 - 10
    switchport mode access
    no shut
    switchport access vlan 65
    channel-group 3 mode active
    channel-protocol lacp
    end
    
    Thank you for your help
    
    
    ________________________________
    From: Paul Angus <paul.angus@shapeblue.com<mailto:paul.angus@shapeblue.com>>
    To: "users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>" <users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>>;
Luis <lmartinez073@yahoo.com<mailto:lmartinez073@yahoo.com>>
    Sent: Thursday, September 7, 2017 3:05 PM
    Subject: RE: Configuring CS with Advance Networking for an internal laboratory
    
    Hi Luis,
    
    You can give CloudStack a range of RFC1918 addresses (ie private addresses) to act as
an 'internal' public network.
    
    10.0.1.10 - 10.0.1.30
    GW: 10.0.1.254
    Netmask - 255.255.255.0
    
    If the gateway at 10.0.1.254 can route to the outside world then CloudStack will still
be able to download templates, if not you can always register a template which you are hosting
on an internal network.
    
    If you do the second option ensure that the global setting 'secstorage.allowed.internal.sites'
 includes the hosting server's IP address.
    
    
    
    Kind regards,
    
    Paul Angus
    
    paul.angus@shapeblue.com<mailto:paul.angus@shapeblue.com>
    www.shapeblue.com<http://www.shapeblue.com>
    53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue
    
    
    
    -----Original Message-----
    From: Luis [mailto:lmartinez073@yahoo.com.INVALID<mailto:lmartinez073@yahoo.com.INVALID>]
    Sent: 07 September 2017 18:42
    To: Users <users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>>
    Subject: Configuring CS with Advance Networking for an internal laboratory
    
    Hi
    I am configuring CS with Advance Networking for internal use without rotatable IP's, this
is for testing and lean CS Advance Networking, This is what I have CS 4.10XenServer 7.0FreeNas
CS is already installed but I can't download any iso because V-Router can't ping outside my
network, any advice?
    Public IP:209.229.131.0Internal IP: 10.0.0.0 Thank you for your help.
    
    
    
       

DISCLAIMER
==========
This e-mail may contain privileged and confidential information which is the property of Accelerite,
a Persistent Systems business. It is intended only for the use of the individual or entity
to which it is addressed. If you are not the intended recipient, you are not authorized to
read, retain, copy, print, distribute or use this message. If you have received this communication
in error, please notify the sender and delete all copies of this message. Accelerite, a Persistent
Systems business does not accept any liability for virus infected mails.
Mime
View raw message