cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asanka Gunasekara <asa...@nimbus.lk>
Subject Re: Secondary storage is not secondary properly
Date Thu, 10 Aug 2017 16:17:50 GMT
Thank you Dag,

On 10 Aug 2017 3:09 am, "Dag Sonstebo" <Dag.Sonstebo@shapeblue.com> wrote:

Sure, let us know how you get on. The fact that the previous ssvm check
showed up with 172.17.101.1 was probably down to the wrong “host” global
setting – since the SSVM didn’t know where to contact management I would
guess it used a default override.

Regards,
Dag Sonstebo
Cloud Architect
ShapeBlue
 S: +44 20 3603 0540  | dag.sonstebo@shapeblue.com |
http://www.shapeblue.com <http://www.shapeblue.com/> | Twitter:@ShapeBlue <
https://twitter.com/#!/shapeblue>


On 09/08/2017, 17:54, "Asanka Gunasekara" <asanka@nimbus.lk> wrote:

    Hi Dag, pleas give me few days as I am on an implementation visit to a
    remote site. But below are some of the test I performed before.

    1. Ping from ssvm to NFS is possible
    2. Manually mounting NFS to /tmp/secondary is possible without any Issy

    From the previous run of the ssvm check it is looking for a serve IP
    172.17.101.1. Where registered NFS share is 172.17.101.253

    I will run the check again on the first chance I get

    Thank you and best regards

    Asanka


    On 9 Aug 2017 12:55 pm, "Dag Sonstebo" <Dag.Sonstebo@shapeblue.com>
wrote:

    OK , can you post up the results of the ssvm check again?

    As suggested previously on this thread – can you try to
    1) Ping the NFS server from the SSVM (SSVM check does this as well) – if
    this doesn’t work then you have a networking issue.
    2) Depending on ping - manually mount the secondary NFS share on your
SSVM.
    If this doesn’t work then you need to investigate the logs at the NFS
end
    to see why the NFS handshake fails.

    Regards,
    Dag Sonstebo
    Cloud Architect
    ShapeBlue

    On 08/08/2017, 19:14, "Asanka Gunasekara" <asanka@nimbus.lk> wrote:

        Hi Dag

        After changing localhost to management server ip oin global
    configuration I
        dont see the management server error. But the NFS error still
persist

        Thanks and Regards

        Asanka


    Dag.Sonstebo@shapeblue.com
    www.shapeblue.com
    53 Chandos Place, Covent Garden, London  WC2N 4HSUK
    @shapeblue




Dag.Sonstebo@shapeblue.com
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue



On 8 August 2017 at 23:33, Asanka Gunasekara <asanka@nimbus.lk> wrote:

        > Hi Dag, thanks for reply
        >
        > Did the change and the VMs are being rebuilt
        >
        > NFS server configuration, I took this from the installation guied
        >
        > [root@share ~]# cat /etc/exports
        > /share_smb/export/secondary *(rw,async,no_root_squash,no_
    subtree_check)
        > /share_smb/export/primary *(rw,async,no_root_squash,no_
subtree_check)
        > [root@share ~]#
        >
        >
        > On 8 August 2017 at 17:06, Dag Sonstebo <
Dag.Sonstebo@shapeblue.com>
        > wrote:
        >
        >> Hi Asanka,
        >>
        >> Can you change your “host” global setting to your management
server
    IP
        >> (it’s currently set to “localhost”), restart your management
service
    and
        >> then destroy your SSVM + let this recreate.
        >>
        >> Once done run the check again and let us know the outcome.
        >>
        >> Can you also show us the configuration of your NFS share – i.e.
what
        >> parameters are set etc.
        >>
        >> Regards,
        >> Dag Sonstebo
        >> Cloud Architect
        >> ShapeBlue
        >>
        >> On 08/08/2017, 10:28, "Asanka Gunasekara" <asanka@nimbus.lk>
wrote:
        >>
        >>     Hi Guys,
        >>
        >>     ssvm-check.sh command output
        >>
        >>     https://snag.gy/bzpE5n.jpg
        >>
        >>     Details of my nfs share
        >>
        >>     https://snag.gy/WgJxCY.jpg
        >>
        >>     Thanks and Best Regards
        >>
        >>     Asanka
        >>
        >>
        >>
        >>
        >> Dag.Sonstebo@shapeblue.com
        >> www.shapeblue.com
        >> 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
        >> @shapeblue
        >>
        >>
        >>
        >> On 8 August 2017 at 14:48, Asanka Gunasekara <asanka@nimbus.lk>
    wrote:
        >>
        >>     > Thanks Makrand
        >>     >
        >>     > On 8 August 2017 at 14:42, Makrand <makrandsanap@gmail.com>
    wrote:
        >>     >
        >>     >> Asanka,
        >>     >>
        >>     >> The email list blocks the screen shots. I guess no one in
the
    list
        >> can see
        >>     >> your posted screens in emal chain.
        >>     >>
        >>     >> Better paste text output of the result or upload screens
to
    image
        >> hosting
        >>     >> (e.g. snag.gy).
        >>     >>
        >>     >> --
        >>     >> Makrand
        >>     >>
        >>     >>
        >>     >> On Tue, Aug 8, 2017 at 2:28 PM, Asanka Gunasekara <
        >> asanka@nimbus.lk>
        >>     >> wrote:
        >>     >>
        >>     >> > Hi Guys, thanks for replying buy running ssvm-check.sh
I got
        >> below
        >>     >> output
        >>     >> >
        >>     >> >
        >>     >> > [image: Inline images 1]
        >>     >> >
        >>     >> > My nfs is 172.17.101.253 but it is looking for
172.17.101.1
        >> which is the
        >>     >> > gateway and the Management server is 172.17.101.248 but
it
    is
        >> looking
        >>     >> in to
        >>     >> > Loval host
        >>     >> >
        >>     >> >
        >>     >> >
        >>     >> >
        >>     >> > [image: Inline images 2]
        >>     >> >
        >>     >> > What is going on, have I done something wrong?
        >>     >> >
        >>     >> > On 8 August 2017 at 14:22, Dag Sonstebo <
        >> Dag.Sonstebo@shapeblue.com>
        >>     >> > wrote:
        >>     >> >
        >>     >> >> Hi Asanka,
        >>     >> >>
        >>     >> >> One quick thing to check – log in to your SSVM and
run
        >>     >> >> /use/local/cloud/systemvm/ssvm-check.sh – this will
tell
    you
        >> if the
        >>     >> SSVM
        >>     >> >> can mount and write to secondary storage.
        >>     >> >>
        >>     >> >> Regards,
        >>     >> >> Dag Sonstebo
        >>     >> >> Cloud Architect
        >>     >> >> ShapeBlue
        >>     >> >>
        >>     >> >> From: Asanka Gunasekara <asanka@nimbus.lk>
        >>     >> >> Reply-To: "users@cloudstack.apache.org" <
        >> users@cloudstack.apache.org>
        >>     >> >> Date: Tuesday, 8 August 2017 at 09:27
        >>     >> >> To: "users@cloudstack.apache.org" <
    users@cloudstack.apache.org>
        >>     >> >> Subject: Re: Secondary storage is not secondary
properly
        >>     >> >>
        >>     >> >> I am sorry Eric, thank you for replying, please see
below
    for
        >> the rest
        >>     >> >> results
        >>     >> >>
        >>     >> >> * Make sure that it's accessible from the *storage*
    network (the
        >>     >> network
        >>     >> >> that you configured as storage when you created the
zone,
        >> assuming you
        >>     >> >> selected advanced networking).
        >>     >> >> Asanka > Since this is a test environemt I have
just
made
    it
        >> all in one
        >>     >> >> subnet (is that the issue)
        >>     >> >>
        >>     >> >> * Is the secondary storage virtual machine up and
running?
        >> Check your
        >>     >> >> Infrastructure tab.
        >>     >> >> Asanka > Yes both system VMs are up and running
        >>     >> >>
        >>     >> >> * If the secondary storage virtual machine is up and
    running,
        >> open its
        >>     >> >> console and log in as root / password. Then check 'ip
addr
        >> list' to
        >>     >> make
        >>     >> >> sure that it has IP addresses.
        >>     >> >> Asanka > Yes it IP are assigned
        >>     >> >>
        >>     >> >> * If it has IP addresses, try pinging your secondary
    storage
        >> NFS server
        >>     >> >> (still within the SSVM).
        >>     >> >> Asanka > I can ping secondary storage
        >>     >> >>
        >>     >> >> * If you can ping your secondary storage NFS server,
try
        >> mounting the
        >>     >> NFS
        >>     >> >> share at some random place in your filesystem to make
sure
    you
        >> can
        >>     >> mount it
        >>     >> >> from the SSVM. e.g., 'mkdir /tmp/t; mount
        >> myserver:/export/secstorage
        >>     >> >> /tmp/t'
        >>     >> >> Asanka > I can mount the secondary storage as below
        >>     >> >>
        >>     >> >>
        >>     >> >> [nline images 1]
        >>     >> >>
        >>     >> >>
        >>     >> >> Dag.Sonstebo@shapeblue.com
        >>     >> >> www.shapeblue.com
        >>     >> >> 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
        >>     >> >> @shapeblue
        >>     >> >>
        >>     >> >>
        >>     >> >>
        >>     >> >> On 8 August 2017 at 12:54, Eric Green <
    eric.lee.green@gmail.com
        >> <mail
        >>     >> to:
        >>     >> >> eric.lee.green@gmail.com>> wrote:
        >>     >> >>
        >>     >> >> > On Aug 7, 2017, at 23:44, Asanka Gunasekara <
    asanka@nimbus.lk
        >>     >> <mailto:
        >>     >> >> asanka@nimbus.lk>> wrote:
        >>     >> >> > NFS is running on a different server, I can manual
mount
    this
        >> share
        >>     >> as
        >>     >> >> NFS
        >>     >> >> > and SMB
        >>     >> >> > Cloud stack - 4.9
        >>     >> >> > Os is Centos 7 (64)
        >>     >> >>
        >>     >> >> * Make sure that it's accessible from the *storage*
    network (the
        >>     >> network
        >>     >> >> that you configured as storage when you created the
zone,
        >> assuming you
        >>     >> >> selected advanced networking).
        >>     >> >> * Is the secondary storage virtual machine up and
running?
        >> Check your
        >>     >> >> Infrastructure tab.
        >>     >> >> * If the secondary storage virtual machine is up and
    running,
        >> open its
        >>     >> >> console and log in as root / password. Then check 'ip
addr
        >> list' to
        >>     >> make
        >>     >> >> sure that it has IP addresses.
        >>     >> >> * If it has IP addresses, try pinging your secondary
    storage
        >> NFS server
        >>     >> >> (still within the SSVM).
        >>     >> >> * If you can ping your secondary storage NFS server,
try
        >> mounting the
        >>     >> NFS
        >>     >> >> share at some random place in your filesystem to make
sure
    you
        >> can
        >>     >> mount it
        >>     >> >> from the SSVM. e.g., 'mkdir /tmp/t; mount
        >> myserver:/export/secstorage
        >>     >> >> /tmp/t'
        >>     >> >> * Make sure you're using the NFS server's *storage*
    network IP
        >> address
        >>     >> >> when you make this attempt.
        >>     >> >>
        >>     >> >> It is possible that your NFS server has a firewall
    configured?
        >> But from
        >>     >> >> my experiments, the secondary storage VM not providing
    secondary
        >>     >> storage
        >>     >> >> usually is a networking problem, things not set up
    properly in
        >> your
        >>     >> zone's
        >>     >> >> networking so that the secondary storage VM can't
reach the
        >> secondary
        >>     >> >> storage. Are you using advanced networking, or basic
    networking?
        >>     >> >>
        >>     >> >>
        >>     >> >
        >>     >>
        >>     >
        >>     >
        >>
        >>
        >>
        >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message