cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Ubuntu 14.04 + qemu 2.5 vs. ACS 4.8 advice needed
Date Fri, 21 Jul 2017 13:18:43 GMT
Hi all,

we are using ACS 4.8, on Ubuntu 14.04 (stock version qemu/libvirt -
2.0.0/1.2.2) and we have issues during live migration of "busy" VMs (high
RAM change rate), so we plan to introduce additional flag+global parameter
in ACS, which will auto converge flag libvirt to enable auto convergence
(thanks Mike. T :) )

qemu 1.6+ supports auto convergence, but before 2.5 it's mostly useless
(based on docs and my own testing)

Since we cant upgrade to Ubuntu 16.04 before ACS 4.9 or 4.10 release, we
are forced to play with qemu/libvirt verisons, so I used Ubuntu OpenStack
repo for "MITAKA" release, which provides QEMU 2.5 / LIBVIRT 1.3.1 (auto
convergence works like charm).


Now, we are facing different issues that ACS send command to libvirt, but
libvirt basically do some silly things and cant start some VMs at all, etc.

Anyone running ACS 4.8 with qemu 2.5+ and libvirt 1.3 , any advice how to
proceed (our developers are already debugging things, but this takes time) ?

Any info is really appreciated.

Thanks !

-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message