cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roman Ledovskiy <roman.ledovs...@exalit.com>
Subject ethNone problem with VPC
Date Wed, 14 Jun 2017 12:59:15 GMT
Hi Everyone,

Does anyone encounter "ethNone" interfaces in VPC routers? 

I'm running cloudstack 4.9.2.0 with KVM hypervisor and every time I create VPC router it fails
to do proper setup, with errors:
====
Traceback (most recent call last):
  File "/opt/cloud/bin/configure.py", line 931, in main
    config.address().process()
  File "/opt/cloud/bin/cs/CsAddress.py", line 103, in process
    ip = CsIP(dev, self.config)
  File "/opt/cloud/bin/cs/CsAddress.py", line 256, in __init__
    self.dnum = hex(int(dev[3:]))
ValueError: invalid literal for int() with base 10: 'None'
====

Only local link IP (eth0) is up.

/etc/cloudstack/ips.json inside my VPC routers always look like this (I guess this explains
above):
====
{
    "eth0": [
        {
            "add": true,
            "broadcast": "169.254.255.255",
            "cidr": "169.254.1.238/16",
            "device": "eth0",
	.....
	...
        }
    ],
    "ethNone": [
        {
            "add": true,
            "broadcast": "X.Y.Z.255",
            "cidr": "Y.Y.Z.43/24",
            "device": "ethNone",
	.....
	....
        }
    ],
    "id": "ips"
}
====

X.Y.Z.0/24 is my public network

If I manually edit /etc/cloudstack/ips.json (change ethNone to eth1) - then restart VPC router
manually (via virsh) - everything works, interfaces/iptables are up.. 
Until next time I do anything with this VPC from GUI - then ethNone reappears and everything
is broken again..

Appreciate if anyone has any thoughts.


Thanks
Roman



Mime
View raw message