Hi Vivek,

 

Version is centos-release-6-5.el6.centos.11.2.x86_64

 

Nss* packages before update are

 

nss-softokn-freebl-3.14.3-23.3.el6_8.x86_64

nss-tools-3.21.3-2.el6_8.x86_64

nss-util-3.21.3-1.el6_8.x86_64

nss-softokn-3.14.3-23.3.el6_8.x86_64

nss-3.21.3-2.el6_8.x86_64

nss-sysinit-3.21.3-2.el6_8.x86_64

nss-softokn-freebl-3.14.3-23.3.el6_8.i686

 

I’ve just updated all nss* packages, restart of MS, destroy & replace SSVM did not help.

 

I will try a full yum update tomorrow, just in case we missed something last time we tried.

 

Jason

 

From: Vivek Kumar <vivek.kumar@indiqus.com>
Reply-To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>
Date: Tuesday, 23 May 2017 at 11:55 pm
To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>
Subject: Re: SSVM NIO SSL Handshake error

 

Hello Jason,

 

I also faced this issue  earlier with my centos 6, can you confirm the exact version of centos ?, and if possible please update all packages related to nss* and then restart the management services. 

 

Vivek Kumar
Virtualization and Cloud Consultant


 
IndiQus Technologies Pvt Ltd 
A-98, LGF, C.R.Park, New Delhi - 110019 
24x7 +91 11 4055 1409 | M +91 7503460090 
www.indiqus.com

 

On 23-May-2017, at 6:35 PM, Jason Kinsella <jason@cloudpeople.com.au> wrote:

 

Hi Erik,
Yes - the box is a CentOS 6 box. It hadn’t been updated in a while, but we did a full update without fixing it. Also, the dev server is exactly the same CentOS 6 version and happily running 4.9.2.0
Thanks,
Jason



On 23/5/17, 10:56 pm, "Erik Weber" <terbolous@gmail.com> wrote:

   What's the OS? Think I saw something like this on some old CentOS 6 machines

   --
   Erik

   On Tue, May 23, 2017 at 2:11 PM, Jason Kinsella
   <jason@cloudpeople.com.au> wrote:

Hi,
We recently upgraded from 4.5.0 to 4.9.2.0 and encountered a problem with the SSVM and Console Proxy. They cannot connect to the management server. The SSVM cloud.log repeats this error every couple of seconds.

2017-05-23 11:58:22,461 INFO  [utils.nio.NioClient] (main:null) Connecting to 192.168.12.1:8250
2017-05-23 11:58:22,465 WARN  [utils.nio.Link] (main:null) This SSL engine was forced to close inbound due to end of stream.
2017-05-23 11:58:22,465 ERROR [utils.nio.Link] (main:null) Failed to send server's CLOSE message due to socket channel's failure.
2017-05-23 11:58:22,466 ERROR [utils.nio.NioClient] (main:null) SSL Handshake failed while connecting to host: 192.168.12.1 port: 8250
2017-05-23 11:58:22,466 ERROR [utils.nio.NioConnection] (main:null) Unable to initialize the threads.
java.io.IOException: SSL Handshake failed while connecting to host: 192.168.12.1 port: 8250
               at com.cloud.utils.nio.NioClient.init(NioClient.java:67)
               at com.cloud.utils.nio.NioConnection.start(NioConnection.java:88)
               at com.cloud.agent.Agent.start(Agent.java:237)
               at com.cloud.agent.AgentShell.launchAgent(AgentShell.java:399)
               at com.cloud.agent.AgentShell.launchAgentFromClassInfo(AgentShell.java:367)
               at com.cloud.agent.AgentShell.launchAgent(AgentShell.java:351)
               at com.cloud.agent.AgentShell.start(AgentShell.java:456)
               at com.cloud.agent.AgentShell.main(AgentShell.java:491)
2017-05-23 11:58:22,468 INFO  [utils.exception.CSExceptionErrorCode] (main:null) Could not find exception: com.cloud.utils.exception.NioConnectionException in error code list for exceptions
2017-05-23 11:58:22,468 WARN  [cloud.agent.Agent] (main:null) NIO Connection Exception  com.cloud.utils.exception.NioConnectionException: SSL Handshake failed while connecting to host: 192.168.12.1 port: 8250

The setup is very simple. Single management server and ports are open.

Things checked / tried:

·         Destroyed SSVM multiple times – still same problem.

·         SSH to SSVM from MS using ssh -i /var/cloudstack/management/.ssh/id_rsa -p 3922 root@IPADDRESS – PASS

·         SSVM telnet on 8250 to MS – PASS

I’ve also tested a restore of the DB into our working development 4.9.2.0 server. It also exhibits the handshake errors, so most likely DB related.

I’ve used up all my skills. Please help

Regards,
Jason