cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Poll Garcia <marc.poll.gar...@upcnet.es>
Subject Re: some issues after upgrade cloudstack to 4.9.2
Date Thu, 25 May 2017 10:06:01 GMT
Hello again,

About the Cloudstack version upgrade, we've build it from sources, to
create new self-compiled package 4.9.2 version with "noredit", in order to
achieve VMware hypervisor compatibility.

During that process, we changed some files, trying to get Vmxnet3 as
virtual NIC by default instead of E1000 when new instances are created.

Unfortunatly it does not work either.

That's what we did:
/tmp/apache-cloudstack-4.9.2.0-src

*Change:*
*            // Fallback to E1000 if no specific nicAdapter is passed*
*            VirtualEthernetCardType nicDeviceType =
VirtualEthernetCardType.E1000;*

*Apache-cloudstack-4.9.2.0-src] # cat
./plugins/hypervisors/vmware/src/com/cloud/hypervisor/vmware/resource/VmwareResource.java
| grep VirtualEthernetCardType*
*Import com.cloud.hypervisor.vmware.mo.VirtualEthernetCardType;*
*            VirtualEthernetCardType nicDeviceType =
VirtualEthernetCardType.Vmxnet3;*



Any help on it?

More info:
http://users.cloudstack.apache.narkive.com/LTPpdCh3/vmxnet3-by-default

Many thanks!

Kind regards.

2017-05-25 11:14 GMT+02:00 Marc Poll Garcia <marc.poll.garcia@upcnet.es>:

> Hi all,
>
> we have just upgraded our cloud environment based on Cloudstack 4.5.2 to
> 4.9.2 and we're expriencing some issues after this.
>
> Our setup is the following one:
>
> - 1 x cloudstack managment server
> - 1 x bbdd server cloudstack database on it
> - 2 x Vmware Hipervisors (hosts)
>
> I'm performing a list of tests:
>
> *- Sometimes, and randomly console from instances does not load.*
> *- Not possible to upload template from local.*
>
> We see the following on log:
>
> 2017-05-25 09:00:31,665 ERROR [c.c.s.ImageStoreUploadMonitorImpl]
> (Upload-Monitor-1:ctx-0b3bf6e9) (logid:e9c82a0f) *Template
> b87459ac-8fbe-4b34-ae25-21235c3fcd1d failed to upload due to operation
> timed out*
> 2017-05-25 09:02:18,265 ERROR [c.c.c.ClusterServiceServletContainer]
> (Thread-11:null) (logid:) *Unexpected exception *
> 2017-05-25 09:03:35,940 ERROR [c.c.c.ClusterManagerImpl] (main:null)
> (logid:) *Unable to ping management server at 192.168.100.2:9090
> <http://192.168.100.2:9090> due to ConnectException*
>
>
> Why is it happening?
> It does not happen on our old 4.5.2 version.
>
> Is there any way to fix it? changing any global parameter or permissions
> issue?
>
> We need a clue with that because if affecting to our production
> environment.
>
> Thanks in advance.
>
> Kind regards.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message