cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vivek Kumar <vivek.ku...@indiqus.com>
Subject Re: DNS is not working after adding a private gateway
Date Tue, 18 Apr 2017 06:11:00 GMT
Hello Rene,

I rebooted via API, I mean from cloud stack GUI 
Vivek Kumar
Virtualization and Cloud Consultant


 
IndiQus Technologies Pvt Ltd 
A-98, LGF, C.R.Park, New Delhi - 110019 
24x7 +91 11 4055 1409 | M +91 7503460090 
www.indiqus.com

> On 18-Apr-2017, at 11:39 AM, Rene Moser <mail@renemoser.net> wrote:
> 
> How did you reboot the router? By OS reboot or by cloudstack API?
> 
> Regards
> René
> 
> On 04/17/2017 10:33 PM, Vivek Kumar wrote:
>> Hello Dag,
>> 
>> Yes i have tried to add static route for the remote subnet in the tab of
>> private gateway, and it works as well, but after rebooting the router
>> doesnt resolve DNS, however i can ping to DNS IP but it's not resolving.
>> 
>> So here is my complete scenario:
>> 
>> 1- Create a VPC and create a Tier.
>> 2- I go to my router and everything works fine on router and tier as well.
>> 3- I can see  default route is my public gateway.
>> 4- i also can see 4 interface, one for public, one for link local, one
>> for Tier and last for loopback.
>> 5- then i add a private gateway, and i can see that one more interface
>> is also added in router.
>> 6- I check on my router , everything looks good, internet is working ,
>> DNS is also resolving on router and tier as well.
>> 7- when i reboot my router, everything is stopped working.
>> 
>> i also compared my iptables pre-reboot and post reboot, some changes
>> has been made in iptables post reboot so it might be a cause,
>> 
>> Any idea Dag ?
>> 
>> 
>> *Vivek Kumar*
>> Virtualization and Cloud Consultant____
>> 
>> http://www.indiqus.com/images/logo.jpg  <http://www.indiqus.com/>
>> *I*ndi*Q*us Technologies Pvt Ltd 
>> A-98, LGF, C.R.Park, New Delhi - 110019 
>> *O* +91 11 4055 1409 ( 24*7 Support HelpLine )| *M* +91 7503460090 
>> www.indiqus.com  <http://www.indiqus.com/>
>> 
>> 
>> On Tue, Apr 18, 2017 at 12:36 AM, Dag Sonstebo
>> <Dag.Sonstebo@shapeblue.com <mailto:Dag.Sonstebo@shapeblue.com>> wrote:
>> 
>>    Hi Vivek,____
>> 
>>    __ __
>> 
>>    I’ve not spent a lot of time playing with private gateways – but
>>    have you configured your routing table after adding this (Static
>>    Routes tab on the private gw)?____
>> 
>>    __ __
>> 
>>    Regards,____
>> 
>>    Dag Sonstebo____
>> 
>>    Cloud Architect____
>> 
>>    ShapeBlue____
>> 
>>    __ __
>> 
>>    Dag.Sonstebo@shapeblue.com <mailto:Dag.Sonstebo@shapeblue.com> 
>>    www.shapeblue.com <http://www.shapeblue.com>
>>    @shapeblue
>> 
>> 
>> 
>> 
>>    *From: *Vivek Kumar <vivek.kumar@indiqus.com
>>    <mailto:vivek.kumar@indiqus.com>>
>>    *Reply-To: *"users@cloudstack.apache.org
>>    <mailto:users@cloudstack.apache.org>" <users@cloudstack.apache.org
>>    <mailto:users@cloudstack.apache.org>>
>>    *Date: *Monday, 17 April 2017 at 14:33
>>    *To: *"users@cloudstack.apache.org
>>    <mailto:users@cloudstack.apache.org>" <users@cloudstack.apache.org
>>    <mailto:users@cloudstack.apache.org>>
>>    *Subject: *DNS is not working after adding a private gateway____
>> 
>>    __ __
>> 
>>    Hello Team, ____
>> 
>>    __ __
>> 
>>    I have running ACS 4.7.1 with XenServer 6.5 SP1 and I have
>>    configured  a VPC and everything seems fine and I am able to reach
>>    internet and all vm’s inside the tiers as well, but when I create a
>>    private gateway and reboot the router, it stops working , neither I
>>    am able to reach internet or  able to resolve DNS ( however I am
>>    able to reach IP of any public address i.e 4.2.2.2 and 8.8.8.8 and I
>>    am also using same as a DNS ). Can anyone help me out? Even I tried
>>    to remove the private gateway also but still no luck.____
>> 
>>    __ __
>> 
>>    I tried to trace route from the VR and its saying:____
>> 
>>    __ __
>> 
>>    root@r-960-VM:~# traceroute google.com <http://google.com>____
>> 
>>    google.com <http://google.com>: Name or service not known____
>> 
>>    Cannot handle "host" cmdline arg `google.com <http://google.com>' on
>>    position 1 (argc 1)____
>> 
>>    __ __
>> 
>>    Before Private Gateway it was  running fine.____
>> 
>>    __ __
>> 
>>    *Vivek Kumar*
>>    Virtualization and Cloud Consultant____
>> 
>> 
>> 
>>    IndiQus Technologies Pvt Ltd 
>>    A-98, LGF, C.R.Park, New Delhi - 110019 
>>    24x7 +91 11 4055 1409 | M +91 7503460090 
>>    www.indiqus.com <http://www.indiqus.com> ____
>> 
>>    __ __
>> 
>> 


Mime
View raw message