cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhinandan Prateek <abhinandan.prat...@shapeblue.com>
Subject Re: CloudStack Simulator - Can we test Usage APIs
Date Thu, 20 Apr 2017 03:34:36 GMT
With simulator and cloudstack working you will be getting usage events in cloud.usage_event.
To convert these events to billable data you need to install usage server. This is a separately
installed component.

Form the error it appears that this separate usage server is probably not available/installed.



From: John McDonnell <mcdonnell.john@gmail.com<mailto:mcdonnell.john@gmail.com>>
Reply-To: "users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>" <users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>>
Date: Wednesday, 19 April 2017 at 3:19 PM
To: "users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>" <users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>>
Subject: Re: CloudStack Simulator - Can we test Usage APIs

Hi Koushik,

Thanks you're quick response.

Is there a way to check if is this working/restart it?

I see this in the UI:

[cid:ii_j1osp53s0_15b859cb2222128c]
​

And when I log into the docker container I and attempt to restart the usage server (based
on these docs: http://docs.cloudstack.apache.org/projects/cloudstack-administration/en/latest/usage.html)
. I get:

root@31b33a3c63dd:~# service cloudstack-usage restart
cloudstack-usage: unrecognized service

Am I missing something?

Regards

John


abhinandan.prateek@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 

On 19 April 2017 at 09:51, Koushik Das <koushik.das@accelerite.com<mailto:koushik.das@accelerite.com>>
wrote:
Hi John,
Usage server should work in a simulator setup. The usage service reads data from ‘cloud’
DB and puts it into ‘cloud_usage’ DB. If the data in cloud DB is proper there shouldn’t
be any issues.

Thanks,
Koushik

On 19/04/17, 1:03 PM, "John McDonnell" <mcdonnell.john@gmail.com<mailto:mcdonnell.john@gmail.com>>
wrote:

    Hi,

    I am working on an integration project with CloudStack and in terms of
    testing API calls against a an actual endpoint the cloudstack
    simulator is incredible useful.

    But it doesn't appear to process usage. Is it possible to process
    usage with this simulator?

    When I request usage I get an empty listusagerecordsresponse, I guess
    this is related to the general error in the UI:

    Usage Server

    No usage server process running
    12 Apr 2017 13:56:35

    Is it possible to enable this usage server in the simulator?

    Regards

    John





DISCLAIMER
==========
This e-mail may contain privileged and confidential information which is the property of Accelerite,
a Persistent Systems business. It is intended only for the use of the individual or entity
to which it is addressed. If you are not the intended recipient, you are not authorized to
read, retain, copy, print, distribute or use this message. If you have received this communication
in error, please notify the sender and delete all copies of this message. Accelerite, a Persistent
Systems business does not accept any liability for virus infected mails.



--
John
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message