cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yiping Zhang <yzh...@marketo.com>
Subject Re: VM Data and root VHD missing after storage migration
Date Wed, 15 Mar 2017 18:42:55 GMT
This is a known issue and it was fixed in version no later than 4.5.2. If you search this list
for subject line “corrupt DB after VM live migration with storage migration”, you should
see some past discussions on it.

Good luck!

Yiping

On 3/15/17, 10:51 AM, "Tejas Sheth" <tsheth.p@gmail.com> wrote:

    Hi,
    
      We have xenserver 6.2 with cloudstack 4.3.1. We had initiated the data
    disk migration from one primary storage to another. after the operation we
    were not able to start the VM.
    
      when we checked the xenserver storage, we were not able to find the VHD
    in any of the primary storage.
    
      Its a strange behavior i have seen first time, since the production data
    is missing we need to identify the root cause of the same.
    
    NOTE: Even Root disk is also not available in any of the storage hence we
    are not able to power on the VM at all.
    
     we have checked database where metadata is available in database about the
    root and data disk.
    
      following error captured when we start the vm with Data disk.
    2017-03-09 11:49:26,964 WARN [c.c.h.x.r.CitrixResourceBase]
    (DirectAgent-203:ctx-ff911f73) Catch Exception: class
    com.xensource.xenapi.Types$UuidInvalid due to The uuid you supplied was
    invalid.
    
    Thanks
    

Mime
View raw message