cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeromy Grimmett <jer...@cloudbrix.com>
Subject RE: Problem Enabling back a destroyed VR
Date Fri, 10 Mar 2017 17:34:40 GMT
Glad you were able to resolve it.  Have a great weekend as well!

Jeromy Grimmett
P: 603.766.3625
jeromy@cloudbrix.com
www.cloudbrix.com


-----Original Message-----
From: Özhan Rüzgar Karaman [mailto:oruzgarkaraman@gmail.com] 
Sent: Friday, March 10, 2017 10:49 AM
To: users@cloudstack.apache.org
Subject: Re: Problem Enabling back a destroyed VR

Hi Jeromy;
We have solved the issue, It looks like VR structure changed in 4.9.2 version, on previous
versions when you destroy a vr and redeploy it, VR populates all dhcp and userdata back, but
in this release when you deploy it, it only populates poweron vm's datas.

So because on my test all vm's was powered off it did not populate anything. So its the general
problem.

Thanks for all help and have a nice weekend

Özhan

On Fri, Mar 10, 2017 at 6:35 PM, Jeromy Grimmett <jeromy@cloudbrix.com>
wrote:

> Did you create a new Network Offering that does not have "User Data"
> flagged in the Offering or are you using the system defaulted Offerings?
>
> Jeromy Grimmett
> P: 603.766.3625
> jeromy@cloudbrix.com
> www.cloudbrix.com
>
>
> -----Original Message-----
> From: Özhan Rüzgar Karaman [mailto:oruzgarkaraman@gmail.com]
> Sent: Friday, March 10, 2017 8:42 AM
> To: users@cloudstack.apache.org
> Subject: Problem Enabling back a destroyed VR
>
> Hi;
> I have an environment which is using KVM over ACS 4.9.2 environment, i 
> am using advanced networking with security groups. Today i have 
> destroyed my VR's on my system and after that i noticed that VR does 
> not populate dhcp, password and other informations again, back from management server.
>
> I checked the logs and it looks everything is fine. VR's status is in 
> green running state but i could not start any vm.
>
> To investigate the problem i checked /etc/cloudstack directory and 
> noticed that there is no dhcp, vmdata json files. The directories 
> status is below
>
> root@r-474-VM:/var/cache/cloud# ls -l /etc/cloudstack total 4
> -rw-r--r-- 1 root root  882 Mar 10 13:16 cmdline.json
> -rw-r--r-- 1 root root 1027 Mar 10 13:16 ips.json
> -rw-r--r-- 1 root root  282 Mar 10 12:48 monitorservice.json 
> root@r-474-VM :/var/cache/cloud#
>
> I checked the KVM agent.log files and it says it executed successfully 
> vr_cfg.sh command like below:
>
> 2017-03-10 16:30:59,342 DEBUG [kvm.resource.LibvirtComputingResource]
> (agentRequest-Handler-1:null) Executing:
> /usr/share/cloudstack-common/scripts/network/domr/router_proxy.sh
> vr_cfg.sh
> 169.254.0.200 -c
> /var/cache/cloud/VR-f3c8e852-6a8f-430d-8111-49f15a8aff12.cfg
> 2017-03-10 16:30:59,606 DEBUG [kvm.resource.LibvirtComputingResource]
> (agentRequest-Handler-1:null) Execution is successfu
>
> I connected to the vr and checked the /var/cache/cloud directory and i 
> noticed that there is no VR-f3c8e852-6a8f-430d-8111-49f15a8aff12.cfg file.
>
> I know that management server copies vm's dhcp+vmdata+password details 
> to VR with this file. It looks like maybe there is a problem copying 
> this file, i mean somehow VR could not get its configuration files 
> from Management Server.
>
> I have destroyed other VR's and restarted networks with or without 
> cleanup options but nothing changed same problem on all VR.
>
> Thanks for all help.
>
> Regards
> Özhan
>
Mime
View raw message