cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stavros Konstantaras <s.konstanta...@uva.nl>
Subject Problem shutting down CS4.9 (socket exception)
Date Thu, 08 Dec 2016 14:10:48 GMT
Dear all,

On CentOS 6.7 (with all updates installed) we face a java problem when shutting down CS 4.9
To be more specific, this is the output of the log:

<…>
2016-12-08 14:57:13,528 INFO  [o.a.c.s.l.CloudStackExtendedLifeCycle] (Thread-87:null) (logid:)
stopping bean ClusterServiceServletAdapter
2016-12-08 14:57:13,528 INFO  [o.a.c.s.l.CloudStackExtendedLifeCycle] (Thread-87:null) (logid:)
stopping bean AsyncJobManagerImpl
2016-12-08 14:57:13,528 INFO  [o.a.c.s.l.CloudStackExtendedLifeCycle] (Thread-87:null) (logid:)
stopping bean ClusterManagerImpl
2016-12-08 14:57:13,528 ERROR [c.c.c.ClusterServiceServletContainer] (Thread-9:null) (logid:)
Unexpected exception
java.net.SocketException: Socket closed
	at java.net.PlainSocketImpl.socketAccept(Native Method)
	at java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398)
	at java.net.ServerSocket.implAccept(ServerSocket.java:530)
	at java.net.ServerSocket.accept(ServerSocket.java:498)
	at com.cloud.cluster.ClusterServiceServletContainer$ListenerThread.run(ClusterServiceServletContainer.java:131)
2016-12-08 14:57:13,528 INFO  [c.c.c.ClusterManagerImpl] (Thread-87:null) (logid:) Stopping
Cluster manager, msid : 14038013396216



I tried also with Java 1.8 (instead of the default 1.7) but the problem didn’t solve. I
tried also with Tomcat 6.0.48 (instead of the default 6.0.24) as well but we still get the
same error. Any other ideas? Someone who faced the same error? 

I discovered that the problem exists since CS 4.7 (bug 9227) but it is still marked as unresolved.
Our previous setup was CentOS 6.7 with Java 1.7 and Tomcat 6.0.45 and we didn’t have this
problem. 

Kind Regards
Stavros 

----------------------------
Stavros Konstantaras
Science faculty Research IT support (FEIOG) 
University of Amsterdam, Science Park 904, 1098 XH

Fingerprint: E5E5 9B19 D1CD 88CD 4763  3465 A8DC 7C92 330F D59A


Mime
View raw message