cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kurt K <k...@ihnetworks.com>
Subject Re: Templates are not showing
Date Thu, 10 Nov 2016 05:54:27 GMT
Hi Dag,

We were getting below logs from management server.


====
2016-11-09 21:36:53,096 DEBUG [c.c.a.t.Request] 
(AgentManager-Handler-4:null) Seq 1-4251679523214458881: Processing:  { 
Ans: , MgmtId: 207381009036, via: 1, Ver: v1, Flags: 10, 
[{"com.cloud.agent.api.ModifyStoragePoolAnswer":{"poolInfo":{"host":"162.x.x.x","localPath":"/mnt//380ea4ee-87df-39eb-92f4-730dfea4655a","hostPath":"/export/primary","poolType":"NetworkFilesystem","capacityBytes":979751665664,"availableBytes":977581113344},"templateInfo":{},"result":true,"wait":0}}]

}
2016-11-09 21:36:53,451 INFO  [o.a.c.s.i.TemplateServiceImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) Downloading builtin template 
centos55-x86_64 to data center: 1
2016-11-09 21:36:53,461 DEBUG [o.a.c.s.i.TemplateDataFactoryImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) template 4 is already in store:1, 
type:Image
2016-11-09 21:36:53,571 DEBUG [o.a.c.s.i.TemplateDataFactoryImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) template 4 is already in store:1, 
type:Image
2016-11-09 21:36:53,709 DEBUG [o.a.c.s.i.BaseImageStoreDriverImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) Downloading template to data store 1
2016-11-09 21:36:53,720 WARN  [c.c.s.d.DownloadMonitorImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) There is no secondary storage VM 
for downloading template to image store 
nfs://162.219.249.166/export/secondary
2016-11-09 21:36:53,725 DEBUG [o.a.c.s.i.TemplateDataFactoryImpl] 
(AgentConnectTaskPool-1:ctx-4e501d7e) template 4 is already in store:1, 
type:Image
====

-Kurt

On 11/10/2016 11:05 AM, Kurt K wrote:
> Hi Dag,
>
> We had mounted the NFS share on management server before executed the 
> script. Also there was no  /secondary or other local directory on our 
> management server. All that presented is NFS secondary share.
>
> Can we change any global settings or alter cloud DB entries for the 
> working of this template?
>
> -Kurt
>
>
> On 11/09/2016 07:54 PM, Dag Sonstebo wrote:
>> Hi Kurt,
>>
>> As Simon is hinting at it looks like you didn’t mount the secondary 
>> storage NFS share on your management server before running:
>>
>> "/usr/share/cloudstack-common/scripts/storage/secondary/cloud-install-sys-tmplt 
>>
>> -m /secondary -u
>> http://cloudstack.apt-get.eu/systemvm/4.6/systemvm64template-4.6.0-kvm.qcow2.bz2

>>
>> -h kvm -F"
>>
>> In other words the template downloaded to the local folder /secondary 
>> on the management server rather than to a mounted NFS share.
>> If this is the case delete the contents of your local /secondary 
>> folder, mount the NFS share in the same folder and re-run the script 
>> above.
>>
>> With regards to downloading from the GUI – keep in mind you have a 
>> chicken-and-egg scenario – until you have first downloaded the system 
>> VM template with the above script CloudStack can not create a SSVM, 
>> hence it will not be able to download any further templates.
>>
>> Regards,
>> Dag Sonstebo
>>
>> From: Kurt K <kurt@ihnetworks.com>
>> Reply-To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>
>> Date: Wednesday, 9 November 2016 at 14:14
>> To: "users@cloudstack.apache.org" <users@cloudstack.apache.org>
>> Subject: Re: Templates are not showing
>>
>> Hi Simon,
>>
>> Thanks for the response.
>>
>>   >> Is your secondary storage on a separate NFS server?
>>
>> Yeah, we have used separate NFS server.
>>
>>>> Have you added the secondary storage mount to CloudStack Management?
>> We had tried this.  But no luck.
>>
>> ===
>> 162.x.x.x:/export/secondary nfs 913G 2.0G 865G 1% /mnt/secondary
>> ===
>>
>> However, we have tried to download a CentOS 6.5 ISO directly using 
>> register ISO option from Management UI. There was no downloading 
>> status shows and ready status as no. Please see the below snippets 
>> and attached screen shots.
>>
>> ===
>> [root@nfs1 3]# pwd;ll
>> /export/secondary/template/tmpl/1/3
>> total 315396
>> -rw-r--r--. 1 root root 322954240 Nov 8 23:45 
>> 37ad47be-223d-43ff-ae2c-f10548274c95.qcow2
>> -rw-r--r--. 1 root root 295 Nov 9 04:30 template.properties
>> ===
>>
>> Any idea about this?
>>
>> -Kurt
>>
>>
>> On 11/08/2016 10:25 PM, Simon Weller wrote:
>>
>> Hi Kurt,
>>
>>
>>
>>
>>
>> Is your secondary storage on a separate NFS server?
>>
>>
>>
>> Have you added the secondary storage mount to CloudStack Management?
>>
>>
>>
>>
>>
>> If so, have you tried mounting your secondary storage on a different 
>> server to make sure the permissions are set correctly?
>>
>>
>>
>>
>>
>> - Si
>>
>>
>>
>> ________________________________
>>
>> From: Kurt K <kurt@ihnetworks.com><mailto:kurt@ihnetworks.com>
>>
>> Sent: Tuesday, November 8, 2016 8:48 AM
>>
>> To: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
>>
>> Subject: Fwd: Templates are not showing
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> -------- Forwarded Message --------
>>
>> Subject:         Templates are not showing
>>
>> Date:    Tue, 8 Nov 2016 20:09:17 +0530
>> Dag.Sonstebo@shapeblue.com
>> www.shapeblue.com
>> 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
>> @shapeblue
>>
>>
>>
>> From:    Kurt K <kurt@ihnetworks.com><mailto:kurt@ihnetworks.com>
>>
>> To: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
>>
>>
>>
>>
>>
>>
>>
>> Hi There,
>>
>>
>>
>> We have started to build our own cloud platform on our organization. Our
>>
>> deployment is like a small scale arch. We have used 4 KVM hyper visor
>>
>> servers and 1 management server and 3 storage servers. We have
>>
>> successfully configured all those servers. But while creating the
>>
>> instance, there were no templates shown on management UI. We have
>>
>> downloaded the templates using this script
>>
>> "/usr/share/cloudstack-common/scripts/storage/secondary/cloud-install-sys-tmplt 
>>
>>
>> -m /secondary -u
>>
>> http://cloudstack.apt-get.eu/systemvm/4.6/systemvm64template-4.6.0-kvm.qcow2.bz2

>>
>>
>> -h kvm -F", it was on secondary partition. But didn't show up there on
>>
>> management UI. Is there any other thing need to be done to show up
>>
>> templates on UI?
>>
>>
>>
>> Any help or suggestions from your end is much appreciated.
>>
>>
>>
>> Regards,
>>
>> Kurt K
>>
>>
>>
>>
>>
>>
>>
>> -- 
>> ~Kurt


-- 
*~Kurt *

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message