cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abdul Qayyum Halid <haiy.ha...@gmail.com>
Subject Re: Cloudbr1 not connecting to network(Public or private network), hence SSVM not connected to outside world
Date Fri, 28 Oct 2016 12:02:50 GMT
Hi kumar, yes , my management server able to reach network

On Friday, 28 October 2016, <vivek.kumar@indiqus.com> wrote:

>
>
> Are you able to reach internet on management server ?
>
>
> Get Outlook for Android
>
>
>
>
>
>
> On Fri, Oct 28, 2016 at 5:42 AM +0530, "Abdul Qayyum Halid" <
> haiy.halid@gmail.com <javascript:;>> wrote:
>
>
>
>
>
>
>
>
>
>
> Hi, i am having a problem on network bridging. I had found that my cloudbr1
> doesnt connected to any network, hence my SSVM and CPVM cant ping DNS or
> Gateway excluded the management server althiugh the status is up and
> running. So i can't downlod any ISO. I have flush my IPTABLES on host
> machine trough $sudo iptables -F but its change nothing. Any suggestion on
> networking setup including during zone creation since my SSVM or CPVM eth2
> seems doesn't acquire public ip like 203.XX.XX.XX instead of 172.16.XX.XX.
> Is it necessary that eth2 must to acquire public ip like 203.XX.XX.XX  in
> order to make SSVM or CPVM connected to outside world since i also doesnt
> know my public gateway instead of private gateway which is 172.16.xx.xx.
> Any other fix suggestion are most welcome. Below is my current network
> setup. Btw I have management server and host in same machine. Thank you
>
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
>
> # The primary network interface
> auto eth0
> iface eth0 inet manual
>
> # Public network
> auto cloudbr0
> iface cloudbr0 inet static
>     address 172.16.135.133
>     netmask 255.255.254.0
>     gateway 172.16.135.254
>     dns-nameservers 172.16.238.7 8.8.8.8
>     dns-domain UTP.EDU.MY
>     bridge_ports eth0
>     bridge_fd 5
>     bridge_stp off
>     bridge_maxwait 1
>
> # Private network
> auto cloudbr1
> iface cloudbr1 inet manual
>     bridge_ports eth0.300
>     bridge_fd 5
>     bridge_stp off
>     bridge_maxwait 1
>
> ------------------------------------------------------------
> ----------------------------------------------------------
>
> # SSVM /etc/network/interfaces
> auto lo eth0 eth1 eth2
> iface lo inet loopback
>
> iface  eth0 inet static
>   address 169.254.0.193
>   netmask 255.255.0.0
> iface  eth1 inet static
>   address 172.16.135.146
>   netmask 255.255.254.0
> iface  eth2 inet static
>   address 172.16.135.11
>   netmask 255.255.254.0
>
> ------------------------------------------------------------
> ---------------------------------------------------------
>
> #SSVM health check
>
> ================================================
> First DNS server is  172.16.238.6
> PING 172.16.238.6 (172.16.238.6): 48 data bytes
> --- 172.16.238.6 ping statistics ---
> 2 packets transmitted, 0 packets received, 100% packet loss
> WARNING: cannot ping DNS server
> route follows
> Kernel IP routing table
> Destination     Gateway              Genmask          Flags   Metric Ref
> Use Iface
> 0.0.0.0            172.16.135.254   0.0.0.0               UG      0
> 0        0   eth2
> 169.254.0.0      0.0.0.0              255.255.0.0          U       0
> 0        0   eth0
> 172.16.134.0    0.0.0.0              255.255.254.0       U      0
> 0        0   eth1
> 172.16.134.0    0.0.0.0              255.255.254.0       U      0
> 0        0   eth2
> 172.16.238.6    172.16.135.254  255.255.255.255  UGH   0       0        0
> eth1
> ================================================
> ERROR: DNS not resolving download.cloud.com
> resolv.conf follows
> nameserver 172.16.238.6
> nameserver 172.16.238.7
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message