cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Levitskiy <Sergey.Levits...@autodesk.com>
Subject Re: HA-enabled VM
Date Sat, 08 Oct 2016 15:19:39 GMT
As it turned out on existing VMs it is not enough to change it service offering since the setting
persists during the VM creation and remains the same.
You need to update it for each VM
You can use this sample to update a given service offering and all active VMs that were started
up from it to be HA enabled (rerplace XXXXX with a name of your service offering).  Then stop/start
all VMs to activate this:

update cloud.vm_instance i  
join cloud.disk_offering do on do.id=i.service_offering_id 
join service_offering so on so.id=do.id
set i.ha_enabled=1, so.ha_enabled=1
where i.removed is null and do.name = 'XXXXX'




On 10/8/16, 7:19 AM, "Gian Paolo Buono" <gianpaolo.buono@gesca.it> wrote:

    I've  tried it but not work..any other suggestions?
     bye
    On 10/07/2016 02:46 PM, Sergey Levitskiy wrote:
    
    You can find all service offerings used by those VM and change in service_offereing table
a field ha_enabled to ’1’. After that Stop/Start VMs should make them HA.
    
    
    On 10/7/16, 5:40 AM, "Gian Paolo Buono" <gianpaolo.buono@gesca.it><mailto:gianpaolo.buono@gesca.it>
wrote:
    
        Thanks Boris,
    
        It works.. The problem is that I  have 100 vm without HA, there is a
        charm to enable the HA to all vm  ?
    
        Thanks
    
        On 10/07/2016 02:18 PM, Boris Stoyanov wrote:
        > Hi Gian Paolo,
        >
        > In order to have a VM in HA Enabled state you need to create that VM with Compute
Offering that has “Offer HA” checked.
        >
        > Thanks,
        > Boris Stoyanov
        > boris.stoyanov@shapeblue.com<mailto:boris.stoyanov@shapeblue.com>
        > www.shapeblue.com<http://www.shapeblue.com>
        > 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
        > @shapeblue
        >
        >
        >
        > On Oct 7, 2016, at 3:01 PM, Gian Paolo Buono <gianpaolo.buono@gesca.it><mailto:gianpaolo.buono@gesca.it>
wrote:
        >> Hi all,
        >>
        >> how can i set HA Enabled to yes, in the istance of Vm ? If can't modify
        >> that parameter.
        >>
        >> Thanks
    
    
    
    
    

Mime
View raw message