cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Seeley <jsee...@vertitechit.com>
Subject RE: 4.9 installation failed due to dependency package issue
Date Tue, 23 Aug 2016 17:54:28 GMT
Venkatesh,

I think you need EPEL as a repository to install mysql-connector-python. Try 'yum install
epel-release' and then try again.

Regards,

Jacob Seeley
Sr. Infrastructure Engineer
VertitechIT
413-268-1631

www.vertitechit.com

-----Original Message-----
From: kotipalli venkatesh [mailto:venkateshcloudtest@gmail.com] 
Sent: Tuesday, August 23, 2016 1:48 PM
To: users@cloudstack.apache.org
Subject: 4.9 installation failed due to dependency package issue

HI All,

I am installing cloudstack 4.9 but no luck because some package dependency issue.

OS : Centos 6.8

BaseURL: http://cloudstack.apt-get.eu/centos/6/4.9/


*Below Error we are getting while installation* :

Loaded plugins: fastestmirror, refresh-packagekit, security Setting up Install Process Loading
mirror speeds from cached hostfile
 * base: centos.webwerks.com
 * extras: centos.webwerks.com
 * updates: ftp.iitm.ac.in
Resolving Dependencies
--> Running transaction check
---> Package cloudstack-management.x86_64 0:4.9.0-1.el6 will be 
---> installed
--> Processing Dependency: cloudstack-common = 4.9.0 for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Processing Dependency: ws-commons-util for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Processing Dependency: tomcat6 for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Processing Dependency: mysql-connector-python for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Processing Dependency: mysql-connector-java for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Processing Dependency: ipmitool for package:
cloudstack-management-4.9.0-1.el6.x86_64
--> Running transaction check
---> Package cloudstack-common.x86_64 0:4.9.0-1.el6 will be installed 
---> Package cloudstack-management.x86_64 0:4.9.0-1.el6 will be 
---> installed
--> Processing Dependency: mysql-connector-python for package:
cloudstack-management-4.9.0-1.el6.x86_64
---> Package ipmitool.x86_64 0:1.8.15-2.el6 will be installed Package 
---> mysql-connector-java.noarch 1:5.1.17-6.el6 will be installed
--> Processing Dependency: jta >= 1.0 for package:
1:mysql-connector-java-5.1.17-6.el6.noarch
--> Processing Dependency: slf4j for package:
1:mysql-connector-java-5.1.17-6.el6.noarch
---> Package tomcat6.noarch 0:6.0.24-95.el6 will be installed
*base/filelists_db
                                                                       |
6.4 MB     00:07*
*cloudstack/filelists_db
                                                                       |
 12 kB     00:00 ...*
*extras/filelists_db
                                                                       |
 38 kB     00:00*
*updates/filelists_db
                                                                      | 1.1
MB     00:01*
--> Processing Dependency: tomcat6-lib = 6.0.24-95.el6 for package:
tomcat6-6.0.24-95.el6.noarch
--> Processing Dependency: mx4j for package: 
--> tomcat6-6.0.24-95.el6.noarch Processing Dependency: log4j for 
--> package: tomcat6-6.0.24-95.el6.noarch Processing Dependency: log4j 
--> for package: tomcat6-6.0.24-95.el6.noarch Processing Dependency: jakarta-commons-pool
for package:
tomcat6-6.0.24-95.el6.noarch
--> Processing Dependency: jakarta-commons-dbcp for package:
tomcat6-6.0.24-95.el6.noarch
--> Processing Dependency: jakarta-commons-daemon for package:
tomcat6-6.0.24-95.el6.noarch
--> Processing Dependency: jakarta-commons-collections for package:
tomcat6-6.0.24-95.el6.noarch
---> Package ws-commons-util.noarch 0:1.0.1-13.el6 will be installed
--> Running transaction check
---> Package cloudstack-management.x86_64 0:4.9.0-1.el6 will be 
---> installed
--> Processing Dependency: mysql-connector-python for package:
cloudstack-management-4.9.0-1.el6.x86_64
---> Package geronimo-specs-compat.noarch 0:1.0-3.5.M2.el6 will be 
---> installed
--> Processing Dependency: geronimo-specs = 1.0-3.5.M2.el6 for package:
geronimo-specs-compat-1.0-3.5.M2.el6.noarch
---> Package jakarta-commons-collections.noarch 0:3.2.1-3.5.el6_7 will 
---> be
installed
---> Package jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6 will be 
---> installed Package jakarta-commons-dbcp.noarch 0:1.2.1-13.9.el6 will 
---> be installed Package jakarta-commons-pool.x86_64 0:1.3-12.7.el6 
---> will be installed Package log4j.x86_64 0:1.2.14-6.4.el6 will be 
---> installed Package mx4j.noarch 1:3.0.1-9.13.el6 will be installed
--> Processing Dependency: javamail >= 1.2-5jpp for package:
1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: bcel >= 5.0 for package:
1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: axis >= 1.1 for package:
1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: xml-commons-resolver for package:
1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: jaf for package: 1:mx4j-3.0.1-9.13.el6.noarch
---> Package slf4j.noarch 0:1.5.8-8.el6 will be installed Package 
---> tomcat6-lib.noarch 0:6.0.24-95.el6 will be installed
--> Processing Dependency: tomcat6-servlet-2.5-api = 6.0.24-95.el6 for
package: tomcat6-lib-6.0.24-95.el6.noarch
--> Processing Dependency: tomcat6-jsp-2.1-api = 6.0.24-95.el6 for package:
tomcat6-lib-6.0.24-95.el6.noarch
--> Processing Dependency: tomcat6-el-2.1-api = 6.0.24-95.el6 for package:
tomcat6-lib-6.0.24-95.el6.noarch
--> Processing Dependency: ecj for package: 
--> tomcat6-lib-6.0.24-95.el6.noarch Running transaction check
---> Package axis.noarch 0:1.2.1-7.5.el6_5 will be installed
--> Processing Dependency: wsdl4j for package: 
--> axis-1.2.1-7.5.el6_5.noarch Processing Dependency: jakarta-commons-discovery for package:
axis-1.2.1-7.5.el6_5.noarch
---> Package bcel.x86_64 0:5.2-7.2.el6 will be installed
--> Processing Dependency: regexp for package: bcel-5.2-7.2.el6.x86_64
---> Package classpathx-jaf.x86_64 0:1.0-15.4.el6 will be installed 
---> Package classpathx-mail.noarch 0:1.1.1-9.4.el6 will be installed 
---> Package cloudstack-management.x86_64 0:4.9.0-1.el6 will be 
---> installed
--> Processing Dependency: mysql-connector-python for package:
cloudstack-management-4.9.0-1.el6.x86_64
---> Package ecj.x86_64 1:3.4.2-6.el6 will be installed Package 
---> geronimo-specs.noarch 0:1.0-3.5.M2.el6 will be installed Package 
---> tomcat6-el-2.1-api.noarch 0:6.0.24-95.el6 will be installed Package 
---> tomcat6-jsp-2.1-api.noarch 0:6.0.24-95.el6 will be installed 
---> Package tomcat6-servlet-2.5-api.noarch 0:6.0.24-95.el6 will be
installed
---> Package xml-commons-resolver.x86_64 0:1.1-4.18.el6 will be 
---> installed
--> Running transaction check
---> Package cloudstack-management.x86_64 0:4.9.0-1.el6 will be 
---> installed
--> Processing Dependency: mysql-connector-python for package:
cloudstack-management-4.9.0-1.el6.x86_64
---> Package jakarta-commons-discovery.noarch 1:0.4-5.4.el6 will be
installed
---> Package regexp.x86_64 0:1.5-4.4.el6 will be installed Package 
---> wsdl4j.noarch 0:1.5.2-7.8.el6 will be installed
--> Finished Dependency Resolution
*Error: Package: cloudstack-management-4.9.0-1.el6.x86_64 (cloudstack)*
*           Requires: mysql-connector-python*
 You could try using --skip-broken to work around the problem  You could try running: rpm
-Va --nofiles --nodigest

Please help some one.

Regards,
Venkatesh.k
Mime
View raw message