cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: KVM disk cache option has no effect
Date Thu, 25 Aug 2016 12:06:50 GMT
Example (2 volumes on RBD,1 volume on NFS) - 4.5.1, Ubutnu 14.04

<disk type='network' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <auth username='zzzzzzz'>
        <secret type='ceph' uuid='19291129-4fd4-3c77-a2a5-64632ee5dda1'/>
      </auth>
      <source protocol='rbd'
name='cold-storage/d8e3ee4a-c238-4afe-81b2-e06a0e19655e'>
        <host name=xxxxx' port='6789'/>
      </source>
      <target dev='vda' bus='virtio'/>
      <iotune>
        <read_bytes_sec>41943040</read_bytes_sec>
        <write_bytes_sec>20971520</write_bytes_sec>
        <read_iops_sec>100</read_iops_sec>
        <write_iops_sec>100</write_iops_sec>
      </iotune>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04'
function='0x0'/>
    </disk>
    <disk type='network' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <auth username='yyyy'>
        <secret type='ceph' uuid='19291129-4fd4-3c77-a2a5-64632ee5dda1'/>
      </auth>
      <source protocol='rbd'
name='cold-storage/39a571d4-9b78-4a10-aa9e-8caa86dbb53a'>
        <host name='yyyyy' port='6789'/>
      </source>
      <target dev='vdd' bus='virtio'/>
      <iotune>
        <read_bytes_sec>125829120</read_bytes_sec>
        <write_bytes_sec>125829120</write_bytes_sec>
        <read_iops_sec>1000</read_iops_sec>
        <write_iops_sec>1000</write_iops_sec>
      </iotune>
      <alias name='virtio-disk3'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06'
function='0x0'/>
    </disk>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='writeback'/>
      <source
file='/mnt/14d3778f-b635-3edb-b60e-d43333eb917c/39e0f94a-4454-47a2-b73e-2105f6838142'/>
      <target dev='vde' bus='virtio'/>
      <iotune>
        <read_bytes_sec>125829120</read_bytes_sec>
        <write_bytes_sec>125829120</write_bytes_sec>
        <read_iops_sec>1000</read_iops_sec>
        <write_iops_sec>1000</write_iops_sec>
      </iotune>
      <alias name='virtio-disk4'/>

On 25 August 2016 at 14:02, Andrija Panic <andrija.panic@gmail.com> wrote:

> Guys, I', on 4.5.1, Ubuntu 14.04, and when I edit this field in
> disk_offerings_view, it does work, and  ps aux | grep qemu clearly shows
> cache=writeback
>
> so this might be broken later, and would be good to understand when
> exactly, since we plan upgrade soon to 4.8 release...
>
> cheers
>
> On 25 August 2016 at 11:09, Andrei Mikhailovsky <andrei@arhont.com.invalid
> > wrote:
>
>> I've experimented by using virsh and virtual-manager gui app. The acs gui
>> settings make no difference to the cache settings. I am surprised it has
>> not been working for ages and no one actually fixed it.
>>
>> Cheers
>>
>> ----- Original Message -----
>> > From: "(IMIS) Enzo Bettini" <enzo.b@imisglobal.com>
>> > To: "users" <users@cloudstack.apache.org>
>> > Sent: Wednesday, 24 August, 2016 09:24:50
>> > Subject: Re: KVM disk cache option has no effect
>>
>> > Hi Andrei,
>> >
>> > How did you get around this? Did you manually update the VM
>> > configuration using virsh edit?
>> >
>> > Regards,
>> > Enzo
>> >
>> > On 15/05/2016 00:31, Andrei Mikhailovsky wrote:
>> >> Not as far as I know (. The ticket status is closed
>> >>
>> >> Andrei
>> >>
>> >> ----- Original Message -----
>> >>> From: "Simon Weller" <sweller@ena.com>
>> >>> To: "users" <users@cloudstack.apache.org>
>> >>> Sent: Thursday, 12 May, 2016 14:38:35
>> >>> Subject: Re: KVM disk cache option has no effect
>> >>> All,
>> >>>
>> >>> Is there a current issue in Jira on this?
>> >>>
>> >>> - Si
>> >>>
>> >>>
>> >>>
>> >>>
>> >>>
>> >>> ________________________________________
>> >>> From: Yuriy Karpel <yuriy@karpel.su>
>> >>> Sent: Thursday, May 12, 2016 7:07 AM
>> >>> To: users@cloudstack.apache.org
>> >>> Subject: Re: KVM disk cache option has no effect
>> >>>
>> >>> The same function does not work on centos + ceph. CloudStack 4.7.1
>> >>>
>> >>> 2016-05-12 14:29 GMT+03:00 Andrei Mikhailovsky <andrei@arhont.com>:
>> >>>
>> >>>> Hi Shweta,
>> >>>>
>> >>>> thanks for your findings. I am very much surprised to see this was
>> not
>> >>>> discovered earlier, especially since this feature has been
>> implemented many
>> >>>> versions back (back in version 4.4 or 4.5 i think). I was under
the
>> >>>> impression that people are testing and reporting on the new features
>> before
>> >>>> they hit the release, which apparently is not the case, at least
for
>> some
>> >>>> new features. From what I can see this feature was completed about
a
>> year
>> >>>> ago.
>> >>>>
>> >>>> I've tried to reopen this issue, but i don't have the rights due
to
>> the
>> >>>> Jira being in a temporary Lockdown mode.
>> >>>>
>> >>>> Could someone with the right access reopen this issue on the grounds
>> that
>> >>>> it was reported (by at least two individuals) that this feature
is
>> not
>> >>>> working.
>> >>>>
>> >>>> Many thanks
>> >>>>
>> >>>> Andrei
>> >>>>
>> >>>> ----- Original Message -----
>> >>>>> From: "Shweta Agarwal" <shweta.agarwal1@accelerite.com>
>> >>>>> To: "users" <users@cloudstack.apache.org>
>> >>>>> Sent: Thursday, 12 May, 2016 12:02:59
>> >>>>> Subject: RE: KVM disk cache option has no effect
>> >>>>> Hi Andrei,
>> >>>>>
>> >>>>> Few days back I was also doing some testing in this area and
then we
>> >>>> found out
>> >>>>> that cache field in disk offering is just a UI or API parameter.
>> But in
>> >>>> actual
>> >>>>> implementation of the API we are just neglecting this parameter
. So
>> >>>>> effectively these parameters in disk offering does nothing 
.
>> >>>>>
>> >>>>> Thanks
>> >>>>> Shweta
>> >>>>>
>> >>>>> -----Original Message-----
>> >>>>> From: Andrei Mikhailovsky [mailto:andrei@arhont.com]
>> >>>>> Sent: Thursday, May 12, 2016 4:07 PM
>> >>>>> To: users
>> >>>>> Subject: KVM disk cache option has no effect
>> >>>>>
>> >>>>> Hello
>> >>>>>
>> >>>>> I've been trying to use cache = writeback option for my KVM
>> hypervisor
>> >>>> with ceph
>> >>>>> backend storage. However, when I am launching a vm that uses
the
>> disk
>> >>>> offering
>> >>>>> with cache=writeback, the cache setting is still set to =none
>> according
>> >>>> to the
>> >>>>> ps aux command.The same applies to the root as well as additional
>> data
>> >>>> volumes.
>> >>>>> I am using ACS 4.7.1, both management and hypervisor servers
are
>> Ubuntu
>> >>>> 14.04.
>> >>>>>
>> >>>>> Could someone please advise on how enable writeback cache?
>> >>>>>
>> >>>>> Cheers
>> >>>>>
>> >>>>> Andrei
>> >>>>>
>> >>>>>
>> >>>>>
>> >>>>>
>> >>>>>
>> >>>>> DISCLAIMER
>> >>>>> ==========
>> >>>>> This e-mail may contain privileged and confidential information
>> which is
>> >>>> the
>> >>>>> property of Accelerite, a Persistent Systems business. It is
>> intended
>> >>>> only for
>> >>>>> the use of the individual or entity to which it is addressed.
If
>> you are
>> >>>> not
>> >>>>> the intended recipient, you are not authorized to read, retain,
>> copy,
>> >>>> print,
>> >>>>> distribute or use this message. If you have received this
>> communication
>> >>>> in
>> >>>>> error, please notify the sender and delete all copies of this
>> message.
>> >>>>> Accelerite, a Persistent Systems business does not accept any
>> liability
>> >>>> for
>> > >>>> virus infected mails.
>>
>
>
>
> --
>
> Andrija Panić
>



-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message