cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Beims Bräscher <gabrasc...@gmail.com>
Subject Re: XenServer bond question
Date Tue, 23 Aug 2016 15:06:36 GMT
Are you using Active/Passive bond? (This is the bonding where only one NIC
carries the traffic, others NICs are there just in case the first fails; in
this case is normal other NICs stay as standby.)

XenServer provides support for both, Active/Passive and Active/Active (VM
traffic balanced between bonded NICs).

2016-08-23 11:02 GMT-03:00 Alessandro Caviglione <c.alessandro@gmail.com>:

> Mmm... LACP provide load balancing so I should have 2 channel with 1 Gbps
> throughput...
> In fact, running this command from an XS server, I'm expecting to see both
> NIC "working":
>
>  time dd if=/dev/zero of=/var/run/sr-mount/UUID/testfile bs=4k
> count=300000
>
> But I see only 1 NIC with high traffic, the second one is in complete
> standby!
>
> On Mon, Aug 22, 2016 at 11:31 PM, Marty Godsey <marty@gonsource.com>
> wrote:
>
> > LACP does not provide more throughput but does provide more bandwidth.
> > Basically if you have two 1G NICs in an LACP bond, you will not get a
> > stream faster than 1G.. However, since you are not load balancing, you
> can
> > have MORE 1Gb streams.
> >
> > So what your seeing is normal.
> >
> > Also do a ovs-vsctl list port and a xe bond-list params=all to make sure
> > your bonds are negotiating properly.
> >
> >
> > Regards,
> > Marty Godsey
> >
> > -----Original Message-----
> > From: Alessandro Caviglione [mailto:c.alessandro@gmail.com]
> > Sent: Monday, August 22, 2016 4:02 PM
> > To: users@cloudstack.apache.org
> > Subject: XenServer bond question
> >
> > Hi guys,
> > pheraps I should post this question on Citrix forum but I think that here
> > I can find a more "practical" answer based on similar infrastructure. :)
> > I've a CS 4.6 with XS 6.2 clusters and here's my network config:
> >
> > - Management + Storage: 2 NIC LACP
> > - Guest: 2 NIC LACP
> > - Public: 2 NIC LACP
> >
> > All the "2 NIC" goes to a 2 stack switches with LACP configured.
> > Now, here (
> > http://support.citrix.com/servlet/KbServlet/download/
> > 38321-102-714737/XenServer-6.5.0_Administrators%20Guide.pdf)
> > I see:
> >
> > [...]Management interfaces
> >
> > You can bond a management interface to another NIC so that the second NIC
> > provides failover for management traffic. Although configuring a LACP
> link
> > aggregation bond provides load balancing for management traffic,
> > active-active NIC bonding does not.[...]
> >
> > Ok, great, this is exactly what I need to have.
> >
> > My issue is: in all XS I see only one NIC to make traffic during Storage
> > Migration, I'm expecting that with LACP I see both NIC to make traffic,
> but
> > this does not happen.
> >
> > Do you have any experience on this topic?
> > Since we're migrating to XS6.5 adding a new cluster and moving VM, do you
> > have a better NIC configuration to suggest?
> >
> > Thank you very much!
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message