cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Seitz <s.se...@secretresearchfacility.com>
Subject problem with ldap authentication w/ grouOfNames
Date Fri, 22 Jul 2016 14:22:34 GMT
Hi guys!

We've currently setup acs 4.8 and trying to integrate the
authentication for different domains with different kind of grouOfNames
using openldap.

Users are getting imported, but are unable to authenticate with
following log:


2016-07-22 16:10:50,523 INFO  [o.a.c.l.LdapContextFactory] (catalina-
exec-19:ctx-25b685df) (logid:f6a56bdc) LDAP SSL enabled.
2016-07-22 16:10:50,527 DEBUG [o.a.c.l.LdapContextFactory] (catalina-
exec-19:ctx-25b685df) (logid:f6a56bdc) initializing ldap with provider
url: ldaps://XXXXX:636
2016-07-22 16:10:50,589 DEBUG [o.a.c.l.LdapManagerImpl] (catalina-exec-
19:ctx-25b685df) (logid:f6a56bdc) ldap Exception: 
javax.naming.NamingException: No user found for basedn
ou=Groups,dc=XXXX,dc=YY and searchString
(&(objectClass=inetOrgPerson)(uid=NNNNN))

Interestingly enough, the basedn is expanded to ou=Groups,.... rest of
the dn is ok.

I'ld expecting an ldapquery with the given basedn instead of
ou=Groups,basedn...

could someone please shed some light where or how to configure this
searchfilter?

we double-checked the entries for:
ldap.basedn	set to our base
ldap.group.object groupOfNames
ldap.group.user.uniquemenber member

as said, importing the users is working as expected.

Thanks in advance!

cheers,

- Stephan

Mime
View raw message