cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilya <ilya.mailing.li...@gmail.com>
Subject Re: Help with Usage data - There is no data from Cloudmonkey of types: 4,5,10,21,22,23 or 24 (Network and VM Disk data)
Date Tue, 21 Jun 2016 05:57:21 GMT
Cory

Just curious if you made any headway on this issue or still need help.

Regards
ilya

On 6/17/16 8:38 AM, Cory Fuchs wrote:
> Hello Everyone,
> 
> 
> I hope that someone can point me in the direction of how to resolve my issue and let
me know what I am doing wrong.
> 
> 
> Cloudstack version: 4.5.2
> 
> 
> Running the following command from Cloudmonkey returns no results.
> 
> 
>      list usagerecords startdate=2016-06-16 enddate=2016-06-17 type=4
> 
> 
> Changing the type to any of the following returns no results: 4, 5, 10, 21, 22, or 23
> 
> Changing the type to any of the following does return results: 1, 2, 3, 6, 7, 8, 9, 11,
12, 13, 14, or 25
> 
> 
> This tells me the usage job is running and collecting data.  Just not on the Network
or VM Disk data.
> 
> 
> Looking at /var/log/cloudstack/usage/usage.log
> 
> 
> Grepping for an accountId that I know has usage on.  I get lines like the following.
> 
> 
>      2016-06-17 00:15:03,347 DEBUG [cloud.usage.UsageManagerImpl] (Usage-Job-1:null)
creating networkHelperEntry...accountId: 7 in zone: 1; abr: 142919240951; abs: 40911793471;
curABS: 40911793471; curABR: 142919240951; ubs: 0; ubr: 0
> 
>      2016-06-17 00:15:03,348 DEBUG [cloud.usage.UsageManagerImpl] (Usage-Job-1:null)
getting current accounted bytes for... accountId: 7 in zone: 1; abr: 39361808078; abs: 1006529247
> 
>       2016-06-17 00:15:03,348 DEBUG [cloud.usage.UsageManagerImpl] (Usage-Job-1:null)
creating networkHelperEntry... accountId: 7 in zone: 1; abr: 39361808078; abs: 1006529247;
curABS: 1006529247; curABR: 39361808078; ubs: 0; ubr: 0
> 
> 
> 
> Grepping for account 7.  I get some of the following lines:
> 
> 
>      2016-06-17 00:15:13,976 DEBUG [usage.parser.NetworkUsageParser] (Usage-Job-1:null)
No usage record (0 bytes used) generated for account: 7
> 
>      2016-06-17 00:15:13,976 DEBUG [usage.parser.NetworkUsageParser] (Usage-Job-1:null)
No usage record (0 bytes used) generated for account: 7
> 
>      2016-06-17 00:15:13,976 DEBUG [usage.parser.VmDiskUsageParser] (Usage-Job-1:null)
Parsing all Vm Disk usage events for account: 7
> 
>      2016-06-17 00:15:14,074 DEBUG [usage.parser.VmDiskUsageParser] (Usage-Job-1:null)
No vm disk usage record (0 bytes used) generated for account: 7
> 
>      2016-06-17 00:15:14,074 DEBUG [usage.parser.VmDiskUsageParser] (Usage-Job-1:null)
No vm disk usage record (0 bytes used) generated for account: 7
> 
> 
> Where can I look or what am I doing wrong?
> 
> I am mainly looking for network usage.
> 
> 
> Thank you to anyone that can assist.
> 
> 
> Cory Fuchs
> 
> 
> 

Mime
View raw message