cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: KVM disk cache option has no effect
Date Thu, 12 May 2016 11:29:16 GMT
Hi Shweta,

thanks for your findings. I am very much surprised to see this was not discovered earlier,
especially since this feature has been implemented many versions back (back in version 4.4
or 4.5 i think). I was under the impression that people are testing and reporting on the new
features before they hit the release, which apparently is not the case, at least for some
new features. From what I can see this feature was completed about a year ago.

I've tried to reopen this issue, but i don't have the rights due to the Jira being in a temporary
Lockdown mode.

Could someone with the right access reopen this issue on the grounds that it was reported
(by at least two individuals) that this feature is not working.

Many thanks

Andrei

----- Original Message -----
> From: "Shweta Agarwal" <shweta.agarwal1@accelerite.com>
> To: "users" <users@cloudstack.apache.org>
> Sent: Thursday, 12 May, 2016 12:02:59
> Subject: RE: KVM disk cache option has no effect

> Hi Andrei,
> 
> Few days back I was also doing some testing in this area and then we found out
> that cache field in disk offering is just a UI or API parameter. But in actual
> implementation of the API we are just neglecting this parameter . So
> effectively these parameters in disk offering does nothing  .
> 
> Thanks
> Shweta
> 
> -----Original Message-----
> From: Andrei Mikhailovsky [mailto:andrei@arhont.com]
> Sent: Thursday, May 12, 2016 4:07 PM
> To: users
> Subject: KVM disk cache option has no effect
> 
> Hello
> 
> I've been trying to use cache = writeback option for my KVM hypervisor with ceph
> backend storage. However, when I am launching a vm that uses the disk offering
> with cache=writeback, the cache setting is still set to =none according to the
> ps aux command.The same applies to the root as well as additional data volumes.
> 
> I am using ACS 4.7.1, both management and hypervisor servers are Ubuntu 14.04.
> 
> 
> Could someone please advise on how enable writeback cache?
> 
> Cheers
> 
> Andrei
> 
> 
> 
> 
> 
> DISCLAIMER
> ==========
> This e-mail may contain privileged and confidential information which is the
> property of Accelerite, a Persistent Systems business. It is intended only for
> the use of the individual or entity to which it is addressed. If you are not
> the intended recipient, you are not authorized to read, retain, copy, print,
> distribute or use this message. If you have received this communication in
> error, please notify the sender and delete all copies of this message.
> Accelerite, a Persistent Systems business does not accept any liability for
> virus infected mails.

Mime
View raw message