cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cristian Ciobanu" <cristia...@istream.today>
Subject RE: FW: Password reset, not work after adding new Guest IP Class
Date Tue, 31 May 2016 20:21:09 GMT
Hi Marcus,

      I the all requested tests, successfully, please see in provided images.

      IP to GW: hxxp://imgur.com/a/ON99N ( i also did ping on other GW not allocated on ACS)
 
      IP to IP: hxxp://imgur.com/a/uPlFr ( IP to Linux VM's from ACS environment )

      IP to DNS : hxxp://imgur.com/a/oWrAj
      
   
   Thanks for support!


Regards,
Cristian


-----Original Message-----
From: Marc-Andre Jutras [mailto:marcus@marcuspocus.com] 
Sent: Tuesday, May 31, 2016 6:19 PM
To: users@cloudstack.apache.org
Subject: Re: FW: Password reset, not work after adding new Guest IP Class

Hey Cristian

Can you go on the VR and try to run a ping from there ?

procedure on VR:

1- update the ping util ( apt-get install iputils-ping )

2- run a ping test with different source IP  ( ping -I sourceIP DestIP   
   ctrl-c to stop the ping )

   - source IP : use the IP configured on the VR

   - destination IP : try to ping the gateway, an IP on the other range that should be reachable
and not configured on the VR and another public IP...

   a-1) ping -I 159.X.X.X 167.X.X.X-GW

   a-2) ping -I 159.X.X.X 167.X.X.X-IP

   a-3) ping -I 159.X.X.X 8.8.8.8

   b-1) ping -I 167.X.X.X 159.X.X.X-GW

   b-2) ping -I 167.X.X.X 159.X.X.X-IP

   b-3) ping -I 167.X.X.X 8.8.8.8

   post me the result...

3- re-load the original ping util... ( apt-get install inetutils-ping
-  or destroy / re-create your VR... )

Normally, your core router should know about these two IP ranges, if so, you can just force
the core router to route one IP range to the other range and set only one default gateway
in Cloudstack/public ip range...

Marcus



On 2016-05-31 3:17 AM, Cristian Ciobanu wrote:
> Hi Marcus,
>
>     First of all, thanks for answer.
>
>     - I don't have access to border router ( i will try to get access )
>     - Yes, each IP range have their gateway
>     - I'm not sure why is working after VR reboot/ each reboot, looks 
> lie is doing a switch from , i also provided a screenshot where i run 
> a ping test from IP X to Gateway Y
>
>      Please see:  http://i.imgur.com/T0w3fdZ.jpg
>
>
> Regards,
> Cristian
>      
>
> -----Original Message-----
> From: Marc-Andre Jutras [mailto:marcus@marcuspocus.com]
> Sent: Monday, May 30, 2016 9:46 PM
> To: users@cloudstack.apache.org
> Subject: Re: FW: Password reset, not work after adding new Guest IP 
> Class
>
> Hi Cristian,
>
> Sound like a networking issue // gateway mismatch on your side and not an issue with
ACS: TCP packet seems to be blocked on the border router... ie: ip on 159.X.X.X network is
trying to reach your ACS server via the 167.X.X.X gateway or vice-versa; VR is not managing
two different default gateway !
>
> Do you have some control or can modify config on your border router ? ( where both ip
range got their gateway ? ) if so, check there to allow source IP : 159.X to be able to reach
GW : 167 or vice-versa...
>
> Marcus
>
> On 2016-05-19 4:29 AM, Cristian Ciobanu wrote:
>> Hello All,
>>
>>    
>>
>> I will insist on this topic because i don’t recevied any answer, i just want to
know if is possibile to fix this issue.
>>
>>    
>>
>> Thank you !
>>
>> Cristian
>>
>>    
>>
>> From: Cristian Ciobanu [mailto:cristian.c@istream.today]
>> Sent: Monday, May 16, 2016 10:35 AM
>> To: users@cloudstack.apache.org
>> Subject: RE: Password reset, not work after adding new Guest IP Class
>>
>>    
>>
>> Hello,
>>
>>    
>>
>>       This issue persist, each time i have to reboot the VR.
>>
>>    
>>
>>       Example.
>>
>>      
>>
>>        IP class - X
>>
>>        IP class – Y
>>
>>    
>>
>> 1.      Build VM  from IP class X, password reset on deploy works
>>
>> 2.      Build VM  from IP class X, password reset on deploy works
>>
>> 3.      Build VM  from IP class X, password reset on deploy works
>>
>> 4.      Build VM  from IP class Y, not working
>>
>> 5.      Reboot VR
>>
>> 6.      Build VM  from IP class Y, password reset on deploy works
>>
>> 7.      Build VM  from IP class Y, password reset on deploy works
>>
>> 8.      Remove a VM from IP class X
>>
>> 9.      Build VM from IP class X, not working
>>
>> 10.   Each time is switch from Y to X and vice versa i need to reboot VR
>>
>>    
>>
>>        I have this issue with any OS, also i have 2 Enviorments  with 
>> ACS 4.5.2 Vmware 5.5
>>
>>    
>>
>>      Can i get some help ?
>>
>>    
>>
>> From: Cristian Ciobanu [mailto:cristian.c@istream.today]
>> Sent: Saturday, March 26, 2016 3:06 PM
>> To: users@cloudstack.apache.org <mailto:users@cloudstack.apache.org>
>> Subject: Re: Password reset, not work after adding new Guest IP Class
>>
>>    
>>
>> Can someone help me regarding my issue ?   for sure this is a CS bug, but i need
to know if this can be solved on 4.5.2
>>
>>    
>>
>> Thank you all
>>
>> Cristian
>>
>> On 25.03.2016 21:41:06, Cristian Ciobanu <cristian.c@istream.today <mailto:cristian.c@istream.today>
> wrote:
>>
>> Hi,
>>
>>    
>>
>>         Yes, i have basic zone configured on my ACS environment, also i was able
to see two networks on VR only after i did rebuild for the router.
>>
>>       
>>
>>           1 x IP class 158.X  /28
>>
>>           2 x IP class 167.X  /28
>>
>>    
>>
>>        1. Rebuild router
>>
>>        2. Removed VM's in order to retest a deploy on first (158.X)IP 
>> Class
>>
>>        3. Deploy VM, everything works, also after this deploy i don't 
>> have available IP's from this class (158.X)
>>
>>        4. Deploy VM on secondary IP class (167.X) , password not working, i was able
to login on VM only with static password.
>>
>>        5. Removed VM from class(158.X)
>>
>>        6 Deploy VM on (158.X)  Not working again
>>
>>    
>>
>>         
>>
>>        
>>
>>         Please see the screenshots, i don't provided screenshot from VM when generated
password works :
>>
>>    
>>
>>          Zone/Guest : http://i.imgur.com/h2npDcP.jpg
>>
>>          VR: http://i.imgur.com/TsCTRu6.jpg and 
>> http://i.imgur.com/TsCTRu6.jpg
>>
>>          Pods: http://i.imgur.com/y0Oqgk9.jpg
>>
>>          VR ip a : http://i.imgur.com/7MBzggM.jpg
>>
>>          VM (test linux ) : http://i.imgur.com/uWtTIpI.jpg
>>
>>          VM (test Windows) :http://i.imgur.com/T0w3fdZ.jpg
>>
>>          
>>
>>      Thank you !
>>
>>      
>>
>>    
>>
>> Regards,
>>
>> Cristian
>>
>> On 25.03.2016 19:49:57, Stephan Seitz <s.seitz@secretresearchfacility.com <mailto:s.seitz@secretresearchfacility.com>
> wrote:
>>
>> Hi!
>>
>> Did you add two networks with dhcp? what shows your guests routing 
>> table? obviously two default gateways? did you check if your virtual 
>> router is reachable from within the guest?
>>
>> Am Freitag, den 25.03.2016, 15:18 +0200 schrieb Cristian Ciobanu:
>>> Hello,
>>>
>>> Looks like after adding a second IP class for Guest, password 
>>> generator is not working for New VM on first deploy and password 
>>> reset.
>>>
>>> Password is provided on CloudStack but when i try to login on new VM 
>>> is not working.
>>>
>>> I just added a another /28 for the moment i have 2 x /28 on this 
>>> zone running on ACS 4.5.2 with VMware 5.5.
>>>
>>>
>>> Any info/help ?
>>>
>>>
>>> Thank you !
>>>
>>> Regards,
>>> Cristian
>



Mime
View raw message