cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Klein (RSI)" <rkl...@rsitex.com>
Subject Cloudstack 4.7 password reset issue.
Date Sat, 02 Apr 2016 19:04:44 GMT
First time mailer here, hello everyone.  We are implementing CS 4.7 cluster with CentOS7. 
All is going well with a few bumps that we have resolved.  During testing we are getting an
unusual behavior from the password reset process.  We have setup the templates using the instructions
from the documentation including installing the guest password and SSH setup scripts.  Below
is what happens:

 * Create a VM from template that has the password option checked and the root password is
set as expected.
 * Log in with 1st password and then change password of root via the console of the VM
 * Perform a reboot from the VM console and the password stays as set manually.
 * Power off VM, change PW with CS web GUI.  When the VM is powered on the password is the
new one (as expected).
 * Log in with new password on the console and then manually change root again.
 * Reboot from the console and the password remains as manually set.
 * Power off VM via web GUI and then power it back on.
 * The password reverts to the last password reset operation from the web GUI.

I've looked at the message logs and the guest password and SSH scripts are running normally.
 The virtual router is sending the password reset again when the service query it.  But this
only occurs after the VM is powered off then on again.  I expected the password to remain
as the manually set password but it always reverts to the last password reset operation when
the VM is powered off then on again.

Any insight would be helpful.

Richard KleinĀ  <rklein@rsitex.com> 
RSI 
5426 Guadalupe, Suite 100 
Austin TX 78751 


Mime
View raw message