cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Emrich <martin.emr...@empolis.com>
Subject API deploy virtualmachine failed with custom offering
Date Wed, 23 Mar 2016 13:49:34 GMT
HI!

I try to deploy a virtual machine with a custom offering via the API. But I get "401 unable
to verify user credentials and/or request signature".
First I thought my signing code is wonky (although it worked fine for over a year now)...
But if I use cloudmonkey I get the same:

(local) > deploy virtualmachine zoneid=e99e796c-4e5c-4549-a0d7-ddd3d8526c06 domainid=5b6fbb96-db68-11e3-86e7-0030487e0d0c
name=martin1 serviceofferingid=d16eb08f-ad36-496e-a7bd-b5e43f104ce6 details.cpuSpeed=1000
details.Memory=1024MB details.cpuNumber=2 networkids=0ba76ecd-39cf-403e-bbf7-68e4c44e43ac
templateid=dc3c32ca-21a2-46a4-83f1-229d83b0588d
Error 401 Authentication error
errorcode = 401
errortext = unable to verify user credentials and/or request signature
uuidList:
(local) >

It only happens when I specify the details[0] values, so maybe there's something wrong regarding
the square braces []?

I use ACS 4.8.0, and I remember that it worked some time ago with 4.4.3.

Thanks for any hints!

Regards

Martin


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message