cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Mackey <tmac...@gmail.com>
Subject Re: Failed detecting local storage on XenServer 6.6 slave host
Date Fri, 04 Dec 2015 20:40:00 GMT
Stavros,

Have you enabled local storage within CloudStack (
http://xmodulo.com/how-to-use-local-storage-for-cloudstack-vms.html)?  If
so, its possible local storage implies a CloudStack cluster with only one
host (i.e. you need to break the XenServer pool into independent hosts with
each being in a CloudStack cluster).  I'd need to dig fairly deep in the
code to confirm that theory.

To your question about XenServer Dundee (what you're seeing as 6.6.90),
since it hasn't yet been released by Citrix the visual artifacts (wrong
version number) are to be expected.  Having just checked the database code,
it doesn't look like the work has yet been done to even provide
experimental support for Dundee.  If you would like to remedy that, I think
the community would welcome your contributions, and I could help mentor in
the effort.  Just let me know.

-tim

On Fri, Dec 4, 2015 at 5:37 AM, Stavros Konstantaras <s.konstantaras@uva.nl>
wrote:

> Hi everyone,
>
> At my organisation we tried to build a tiny cluster (1 head, 2 compute
> nodes) with CloudStack 4.6 and XenServer 6.6.90 for experimental reasons.
> As we use local storage for deploying VMs, we discovered that Cloudstack is
> not able to recognise the local storage pool of the slave compute node.
>
> We tried reversing the master node (make the slave compute node ->
> poolmaster and the poolmaster -> slave) but the result was the same. We
> tried Cloudstack 4.5.2 and again problem didn’t solve. We checked the
> database of the poolmaster and it was totally updated and able to detect
> the local storage of the slave node. On Cloudstack-management interface,
> the XenServer 6.6 hosts appear as XenServer 6.5 hosts. In the meanwhile, we
> are totally able to deploy VMs in poolmaster and make use of the local
> storage.
>
> Did any of you face this issue and if yes, did you manage to solve it? I
> suspect that there are some changes in the API of Xenserver 6.6 which CS
> does not support currently.
>
> Best Regards
> Stavros
>
> ----------------------------
> Stavros Konstantaras
> Science faculty Research IT support (FEIOG)
> University of Amsterdam, Science Park 904, 1098 XH
>
> Fingerprint: E5E5 9B19 D1CD 88CD 4763  3465 A8DC 7C92 330F D59A
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message