cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernhard Dübi <1linuxengin...@gmail.com>
Subject Re: CloudStack fails to deploy SSVM
Date Thu, 03 Dec 2015 19:33:14 GMT
Hi,

you can get an excerpt from my management-server.log at level DEBUG at
http://www.due.bi/pub/management-server-debug.zip
the log sais "no pool found" but I can see the primary storage mounted in
the VMware Virtual Center. So, I assume the missing pool is the secondary
storage pool.
do we have a chicken & egg problem: to deploy the SSVM I need the secondary
storage and to access the secondary storage I need the SSVM

Regards
Bernhard

2015-12-02 23:28 GMT+01:00 Somesh Naidu <Somesh.Naidu@citrix.com>:

> The reason for SSVM and CPVM not being deployed would quite likely be the
> same.
>
> Here are the errors relevant to SSVM start failure:
> 2015-12-02 18:19:27,314 INFO  [c.c.s.s.SecondaryStorageManagerImpl]
> (secstorage-1:ctx-f86ee694) Found a stopped secondary storage vm, bring it
> up to running pool. secStorageVm vm id : 3099
> 2015-12-02 18:19:27,417 WARN  [c.c.s.s.SecondaryStorageManagerImpl]
> (secstorage-1:ctx-f86ee694) Exception while trying to start secondary
> storage vm
> com.cloud.exception.InsufficientServerCapacityException: Unable to create
> a deployment for VM[SecondaryStorageVm|s-3099-VM]Scope=interface
> com.cloud.dc.DataCenter; id=4
>
> There are similar for CPVM.
>
> I see that the logging level is set to INFO. Changing to DEBUG will
> provide more pointers on the cause of the failures. I’d suspect storage. I
> believe mgmt server may be trying to deploy the System VMs on local storage
> but there isn’t one available in the new Zone.
>
> Somesh
> CloudPlatform Escalations
> Citrix Systems, Inc.
>
> From: Bernhard Dübi [mailto:1linuxengineer@gmail.com]
> Sent: Wednesday, December 02, 2015 3:12 PM
> To: users@cloudstack.apache.org
> Subject: CloudStack fails to deploy SSVM
>
> Hi,
>
> we have a CloudStack 4.3.2 installation with 152 XenServer 6.2.0 hosts
> organized in 2 zones. We use local disks as primary storage and NFS shares
> as secondary storage. So good so far.
> Now I created a new zone and added a VMware cluster with 2 ESX 5.5 hosts.
> I configured 2 NFS shares as primary and secondary storage. I copied the
> vSphere systemvm to the new secondary storage as described in the
> installation guide.
> If I understand right, this template will be used to deploy the SSVM.
> Unfortunately something is missing and CloudStack fails to deploy the SSVM
> and - probably as a consequence - the Console Proxy
> Please find attached a small part of the management-server.log
>
> Any idea what's wrong? Thanks for your help
>
> Regards
> Bernhard
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message