cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew M. Gamble" <mgam...@thoughtfire.ca>
Subject Cannot create VPC
Date Wed, 30 Dec 2015 18:44:24 GMT
When attempting to create a VPC using 4.7 (with the 4.6 system images) under KVM, I’m getting
the following error on the agent when it attempts to deploy the virtual router:

{"results":["null - success:
 null","null - failed: [INFO] update_config.py :: Processing incoming
 file => ip_associations.json[INFO] Processing JSON file
 ip_associations.jsonTraceback (most recent call last):  File
 \"/opt/cloud/bin/update_config.py\", line 140, in <module>
 process_file()  File \"/opt/cloud/bin/update_config.py\", line 52, in
 process_file    qf.load(None)  File \"/opt/cloud/bin/merge.py\", line
 258, in load    proc = updateDataBag(self)  File
 \"/opt/cloud/bin/merge.py\", line 91, in __init__    self.process()
 File \"/opt/cloud/bin/merge.py\", line 103, in process    dbag =
 self.processIP(self.db.getDataBag())  File \"/opt/cloud/bin/merge.py\",
 line 190, in processIP    dbag = cs_ip.merge(dbag, ip)  File
 \"/opt/cloud/bin/cs_ip.py\", line 32, in merge    ip['device'] = 'eth'
 + str(ip['nic_dev_id'])KeyError:
 'nic_dev_id'"],"result":false,"wait":0}},{"com.cloud.agent.api.Answer":
 {"result":false,"details":"Stopped by previous
 failure","wait":0}},{"com.cloud.agent.api.Answer":{"result":false,"
 details":"Stopped by previous failure","wait":0}}] }

Any ideas where to start debugging this problem?  It looks like the nic_dev_id isn’t being
passed correctly to the VM?


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message