cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: Stuck Upgrading Virtual Router
Date Wed, 30 Dec 2015 10:41:04 GMT
Hi Alessandro,

I think I had a similar issue, which was caused by one of the VRs not starting properly. I
have fixed this by finding the VR and restarting its network with the clean up option.

The cloudstackc-sysvmadm is there to make things easier during the upgrade. You can pretty
much do it manually and it will achieve the same thing. When you restart the network with
the clean up option, ACS would attempt to kill the existing router and recreate it. As you
now have the new systemvm template, the VR and system vms will be created from that template.

I would also take a look at all VRs and system vms to make sure they use the new systemvm
template.

Andrei

----- Original Message -----
> From: "Alessandro Caviglione" <c.alessandro@gmail.com>
> To: "users" <users@cloudstack.apache.org>
> Sent: Tuesday, 29 December, 2015 21:24:58
> Subject: Stuck Upgrading Virtual Router

> Hi all,
> I'm upgrading my little infrastructure from CS 4.4.4 to 4.5.2.
> All worked fine but now the management server is stuck at upgrading VR
> stage.
> I run "nohup cloudstack-sysvmadm -d IPaddress -u cloud -p password -a >
> sysvm.log 2>&1 &" command and the system replied:
> 
> Stopping and starting 1 secondary storage vm(s)...
> Done stopping and starting secondary storage vm(s)
> 
> Stopping and starting 1 console proxy vm(s)...
> Done stopping and starting console proxy vm(s) .
> 
> After that, CS starts to upgrade Routing vm(s):
> 
> Stopping and starting 19 running routing vm(s)...
> 
> 
> Now, after some hours, CS is still there.... but I see that all the VR and
> VPC has been upgraded to 4.5.2.
> 
> How can I conclude the upgrade process?
> Can I simply kill the cloudstack-sysvmadm process?
> 
> Thanks

Mime
View raw message