cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre-Luc Dion <pdion...@apache.org>
Subject Re: Cloudstack-agent can not start
Date Fri, 27 Nov 2015 18:01:49 GMT
Hi Summer,

can you test connectivity from the KVM server that it can connect to your
management server?
host=10.10.0.3
port=8250




On Thu, Nov 26, 2015 at 11:36 PM, Summer Nguyen <summer0nguyen@gmail.com>
wrote:

> Dear cloudstack user & team,
> I'm new to cloudstack and trying to set up a new Cloud for my company
> using Cloudstack with KVM .
> I'm stuck while adding Nodes to Cloudstack as below.
> I have 2 Network :
>
>  * Real Public network :
>      o 10 VLANS
>      o Run on eth0
>      o I want to use for : *Public network
>        *
>  * Real Private Network
>      o 1 VLAN
>      o Run in eth1
>      o I want to use for : Management Network, Storage Network, Guest
>        Network .
>
>
>
> I have 2 Machines :
>
>  * Cloudstack Manager
>      o IP Public : x.x.x.x
>      o IP Private : 10.10.0.3
>      o Cloudstack 4.6
>  * Node
>      o IP Public :  y.y.y.y
>      o IP Private : 10.10.0.10
>      o Cloudstack Agent 4.6
>
>
> I follow the instruction Here:
> http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/4.6/hypervisor/kvm.html
> to Setup KVM Node.
> Network Setup as follow :
>
> *#Public Network , with VLAN TAGGED*
>
> ### ifcfg-eth0
> DEVICE=eth0
> ONBOOT=yes
> NM_CONTROLLED=no
> BOOTPROTO=static
> BRIDGE=cloudbr0
>
>
> ###ifcfg-cloudbr0
> DEVICE=cloudbr0
> TYPE=Bridge
> ONBOOT=yes
>
> NM_CONTROLLED=no
> BOOTPROTO=static
> IPADDR=y.y.y.y
> NETMASK=255.255.255.128
> GATEWAY=....
>
>
> *#Private Network , VLAN 1
> *
>
> ### ifcfg-eth1
> DEVICE="eth1"
> BOOTPROTO="static"
> ONBOOT="yes"
> TYPE="Ethernet"
> BRIDGE=cloudbr1
>
>
> ###ifcfg-cloudbr1
> DEVICE=cloudbr1
> TYPE=Bridge
> ONBOOT=yes
> NM_CONTROLLED=no
> BOOTPROTO=static
> IPADDR=10.10.0.10
> NETMASK=255.255.255.0
>
>
> I can see that cloudstack manager can connect to cloudstack-agent, and
> generate the config like that :
>
> #/etc/cloudstack/agent/agent.properties
>
> guid=fbc93d90-444b-3475-bfa7-1aeb37497766
> resource=com.cloud.hypervisor.kvm.resource.LibvirtComputingResource
> workers=5
> host=10.10.0.3
> port=8250
> cluster=4
> pod=4
> zone=4
> local.storage.uuid=93bdcac7-42f7-43b9-8bbe-ac54b646b16b
> domr.scripts.dir=scripts/network/domr/kvm
> hypervisor.type=kvm
> private.network.device=cloudbr1
> public.network.device=cloudbr0
> guest.network.device=cloudbr1
>
>
> And finally, Here is the error Log :
>
> INFO  [utils.exception.CSExceptionErrorCode] (main:) Could not find
> exception: com.cloud.utils.exception.NioConnectionException in error code
> list for exceptions
> ERROR [cloud.agent.AgentShell] (main:) Unable to start agent:
> com.cloud.utils.exception.CloudRuntimeException: Unable to start the
> connection!
>     at com.cloud.agent.Agent.start(Agent.java:229)
>     at com.cloud.agent.AgentShell.launchAgent(AgentShell.java:399)
>     at
> com.cloud.agent.AgentShell.launchAgentFromClassInfo(AgentShell.java:367)
>     at com.cloud.agent.AgentShell.launchAgent(AgentShell.java:351)
>     at com.cloud.agent.AgentShell.start(AgentShell.java:461)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>     at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>     at java.lang.reflect.Method.invoke(Method.java:606)
>     at
> org.apache.commons.daemon.support.DaemonLoader.start(DaemonLoader.java:177)
> Caused by: com.cloud.utils.exception.NioConnectionException: Connection
> closed with -1 on reading size.
>     at com.cloud.utils.nio.NioConnection.start(NioConnection.java:94)
>     at com.cloud.agent.Agent.start(Agent.java:227)
>     ... 9 more
> Caused by: java.io.IOException: Connection closed with -1 on reading size.
>     at com.cloud.utils.nio.Link.doHandshake(Link.java:513)
>     at com.cloud.utils.nio.NioClient.init(NioClient.java:80)
>     at com.cloud.utils.nio.NioConnection.start(NioConnection.java:88)
>     ... 10 more
> Unable to start agent: Unable to start the connection!
> INFO  [cloud.agent.Agent] (AgentShutdownThread:) Stopping the agent:
> Reason = sig.kill
>
>
> Any suggestion ?
> Thank you very much.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message