cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yan Bai <baiyan...@gmail.com>
Subject Re: SSVM can not connect to Management
Date Thu, 19 Nov 2015 06:18:20 GMT
The java version is 1.7.0_91. Is there anyone solved this issue before? I
think there is something wrong in the Management server so it close the
connection.

Not only the ssvm, one of my host also has this issue. They can not
communicate with management server on port 8250.

-Yan

On Wed, Nov 18, 2015 at 12:09 AM, Rajani Karuturi <rajani@apache.org> wrote:

> what is the java version? upgrading java or nss might help. details at
> http://blog.backslasher.net/java-ssl-crash.html
>
> ~Rajani
>
> On Wed, Nov 18, 2015 at 10:02 AM, Yan Bai <baiyan718@gmail.com> wrote:
>
> > Hi All,
> >
> > I have an issue of connection between SSVM and Management server. I am
> > using Cloudstack 4.5.2 and XenServer 6.2
> >
> > 192.168.1.10 is the Management server. I have turn off firewall of
> > Management server.
> >
> >
> > Below is the error log in SSVM(/var/log/cloud.log):
> >
> > 2015-11-18 04:21:37,989 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> > Connecting to 192.168.1.10:8250
> >
> > 2015-11-18 04:22:38,069 ERROR [utils.nio.NioConnection]
> > (Agent-Selector:null) Unable to initialize the threads.
> >
> > java.io.IOException: Connection closed with -1 on reading size.
> >
> > at com.cloud.utils.nio.Link.doHandshake(Link.java:513)
> >
> > at com.cloud.utils.nio.NioClient.init(NioClient.java:81)
> >
> > at com.cloud.utils.nio.NioConnection.run(NioConnection.java:113)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > 2015-11-18 04:22:43,076 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> > Connecting to 192.168.1.10:8250
> >
> > 2015-11-18 04:23:43,154 ERROR [utils.nio.NioConnection]
> > (Agent-Selector:null) Unable to initialize the threads.
> >
> > java.io.IOException: Connection closed with -1 on reading size.
> >
> > at com.cloud.utils.nio.Link.doHandshake(Link.java:513)
> >
> > at com.cloud.utils.nio.NioClient.init(NioClient.java:81)
> >
> > at com.cloud.utils.nio.NioConnection.run(NioConnection.java:113)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> >
> >
> > I have ran health check in SSVM and everything looks fine:
> >
> > root@s-1-VM:/usr/local/cloud/systemvm# ./ssvm-check.sh
> >
> > ================================================
> >
> > First DNS server is  192.168.1.1
> >
> > PING 192.168.1.1 (192.168.1.1): 48 data bytes
> >
> > 56 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=1.037 ms
> >
> > 56 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.895 ms
> >
> > --- 192.168.1.1 ping statistics ---
> >
> > 2 packets transmitted, 2 packets received, 0% packet loss
> >
> > round-trip min/avg/max/stddev = 0.895/0.966/1.037/0.071 ms
> >
> > Good: Can ping DNS server
> >
> > ================================================
> >
> > Good: DNS resolves download.cloud.com
> >
> > ================================================
> >
> > nfs is currently mounted
> >
> > ================================================
> >
> > Management server is 192.168.1.10. Checking connectivity.
> >
> > Good: Can connect to management server port 8250
> >
> > ================================================
> >
> > Good: Java process is running
> >
> > ================================================
> >
> > Tests Complete. Look for ERROR or WARNING above.
> >
> >
> > I feel like something with SSL connection. Seems that the connection
> > between SSVM and Management server is SSL connection. So maybe something
> > wrong with those ssl keys.
> >
> >
> > -Yan
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message