cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rene Moser <m...@renemoser.net>
Subject Re: Upgrade from 4.5.2 to 4.6
Date Fri, 20 Nov 2015 16:24:35 GMT
Hi Chritian

There is no cloudstack-awsapi anymore since 4.6.

Remove the cloudstack-awsapi-4.5.2-shapeblue0.el6.x86_64 package first
then it should work.

Yours
René


On 11/20/2015 05:13 PM, Rafael Weingärtner wrote:
> There is your problem, right in your log files.
> Did you install the packages from shapeblue before?
> 
> On Fri, Nov 20, 2015 at 2:10 PM, Cristian Ciobanu <cristian.c@istream.today>
> wrote:
> 
>> Hi,
>>
>>      I get error when i execute yum upgrade :
>>
>> [root@mgcs ~]# yum update
>> Loaded plugins: fastestmirror
>> Setting up Update Process
>> Loading mirror speeds from cached hostfile
>>  * base: centos.mirrors.ovh.net
>>  * epel: www.mirrorservice.org
>>  * extras: centos.mirrors.ovh.net
>>  * updates: centos.mirrors.ovh.net
>> cloudstack-4.6
>>                                                                       | 2.9
>> kB     00:00
>> Resolving Dependencies
>> --> Running transaction check
>> ---> Package cloudstack-common.x86_64 0:4.5.2-shapeblue0.el6 will be
>> updated
>> ---> Package cloudstack-common.x86_64 0:4.6.0-shapeblue0.el6 will be an
>> update
>> ---> Package cloudstack-management.x86_64 0:4.5.2-shapeblue0.el6 will be
>> updated
>> --> Processing Dependency: cloudstack-management = 4.5.2 for package:
>> cloudstack-awsapi-4.5.2-shapeblue0.el6.x86_64
>> ---> Package cloudstack-management.x86_64 0:4.6.0-shapeblue0.el6 will be
>> an update
>> --> Finished Dependency Resolution
>> Error: Package: cloudstack-awsapi-4.5.2-shapeblue0.el6.x86_64
>> (@cloudstack-4.5)
>>            Requires: cloudstack-management = 4.5.2
>>            Removing: cloudstack-management-4.5.2-shapeblue0.el6.x86_64
>> (@cloudstack-4.5)
>>                cloudstack-management = 4.5.2-shapeblue0.el6
>>            Updated By: cloudstack-management-4.6.0-shapeblue0.el6.x86_64
>> (cloudstack-4.6)
>>                cloudstack-management = 4.6.0-shapeblue0.el6
>>  You could try using --skip-broken to work around the problem
>>  You could try running: rpm -Va --nofiles --nodigest
>> [root@mgcs ~]#
>>
>>
>> Regards,
>> Cristian
>>
>>
>> On 11/20/2015 6:02:57 PM, Suresh Sadhu <suresh.sadhu@citrix.com> wrote:
>> Hope you already took the db dump.
>>
>> Better practice is ... Stop the management again restore back your db to
>> 4.5.2 and start the management again. Before that just go through logs and
>> analyses why it failed .. that will give clue.
>> If not you will hit the same issue again if you don't address earlier
>> upgrade issue. If there are no user errors then its a bug [if its not clear
>> to you please post the logs we will try to help ]and please raise.
>>
>>
>>
>> Regards
>> Sadhu
>>
>>
>> -----Original Message-----
>> From: Cristian Ciobanu [mailto:cristian.c@istream.today]
>> Sent: Friday, November 20, 2015 9:08 PM
>> To: users@cloudstack.apache.org
>> Subject: Upgrade from 4.5.2 to 4.6
>>
>> Hello,
>>
>>     I try to update the cloudstack management server from 4.5.2 to 4.6 but
>> i get a error, do i need to uninstall the previous version ?
>>
>>
>> Thanks
>>
>>
>>
>> Regards,
>> Cristian
>>
> 
> 
> 

Mime
View raw message