cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Özhan Rüzgar Karaman <oruzgarkara...@gmail.com>
Subject Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken
Date Thu, 22 Oct 2015 12:59:19 GMT
Hi Anderi;
My KVM and ACS servers are updated Ubuntu Trusty 14.03 server. No custom
configs over it. But in this situation ACS server directly talks with Ceph
nodes which are CentOS 7 on my config.

Thanks
Özhan



On Thu, Oct 22, 2015 at 3:17 PM, Andrei Mikhailovsky <andrei@arhont.com>
wrote:

> Hi Ozhan,
>
> very interesting indeed as we seem to be having the same setup. What host
> servers are you running and what version of kvm/qemu?
>
> I have tried Instance > Volume > Volume_Name > Create Template and it
> times out after about 5-10 minutes. This is on a small 50gb volume.
>
> Andrei
> ----- Original Message -----
>
> From: "Özhan Rüzgar Karaman" <oruzgarkaraman@gmail.com>
> To: users@cloudstack.apache.org
> Sent: Thursday, 22 October, 2015 12:35:04 PM
> Subject: Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken
>
> Hi Andrei;
> I am using similar setup(ACS+CEPH+KVM), i first shutdown vm then create
> template(Home >> Instance >> Volumes >> Root-XX) from its root disk
without
> any problem. I am using ACS 4.5.2 and Ceph 0.94.3.
>
> Thanks
> Özhan
>
> On Thu, Oct 22, 2015 at 2:32 PM, Andrei Mikhailovsky <andrei@arhont.com>
> wrote:
>
> > Right, i've done some more testing and here are my results:
> >
> >
> > 1. The template creation from the GUI seem to be broken either by using
> > Volume > Template method or by using Volume > Snapshot > Template.
> >
> > 2. Manual creation of templates work by doing: Volume > Download (Save
> > locally) > Register template (upload locally downloaded volume image).
> >
> > The manual way produces a fully working with correct disk image size
> > template that can be used to create new vm guests. However, it is a
> rather
> > time consuming method, especially for larger volumes.
> >
> >
> > Andrei
> > ----- Original Message -----
> >
> > From: "Andrei Mikhailovsky" <andrei@arhont.com>
> > To: users@cloudstack.apache.org
> > Sent: Thursday, 22 October, 2015 10:57:06 AM
> > Subject: Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken
> >
> > Hi Erik,
> >
> > The ceph itself does not have a concept of templates as such, so it would
> > be hard to create the templates outside of cloudstack. I think the only
> > requirement of ceph here would be the ability to create a volume (which
> it
> > can do successfully already as I am able to create new vm instances) and
> > create a clone from volume, which would be how I imagine ACS would do it
> > when creating a new instance from a template.
> >
> > These things are working fine as I can see from being able to create
> > system vms. So, from what it seems, something must be broken when ACS
> tries
> > to create a template.
> >
> > I will try to do more digging to verify this issue.
> >
> > Could someone one please confirm that they are able to create templates
> > from volumes and snapshots on ACS and Ceph?
> >
> > Many thanks
> >
> >
> >
> > ----- Original Message -----
> >
> > From: "Erik Weber" <terbolous@gmail.com>
> > To: users@cloudstack.apache.org
> > Sent: Thursday, 22 October, 2015 9:34:20 AM
> > Subject: Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken
> >
> > Does it work if you do it manually, ie. outside of cloudstack?
> >
> > Could quite possibly be something wrong with ceph, considering you had
> > issues with VRs as well.
> >
> > --
> > Erik
> >
> > On Thu, Oct 22, 2015 at 10:26 AM, Andrei Mikhailovsky <andrei@arhont.com
> >
> > wrote:
> >
> > > Hello guys,
> > >
> > > Was wondering if this is a known issue that is being addressed?
> > >
> > > I've got ACS 4.5.2 with KVM and Ceph rbd. I am unable to create
> Templates
> > > from existing volumes.
> > >
> > > When I try to create a template from a volume (50GB in size), I have a
> > > timeout error (probably about 5 - 10 minutes after it has been
> > initiated).
> > >
> > > When I try to create a snapshot from the volume and following its
> > > completion create a template from the snapshot, the process does not
> end
> > up
> > > in error. However, the template is unusable for creating virtual
> > machines.
> > > The template size ends up being in thousands of terabytes (at least
> > > according to the ACS gui).
> > >
> > > Is this a known problem or should I open a new bug?
> > >
> > > P.S. I had the same issue with 4.5.1.
> > >
> > > Thanks
> > >
> > > Andrei
> > >
> >
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message