cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Castro <luciano.cas...@gmail.com>
Subject Re: InsufficientServerCapacityException - Fresh install CS 4.5.2 - Xenserver 6.5
Date Wed, 14 Oct 2015 16:59:15 GMT
...

And I cant log in the CS GUI. My workaround was back mysql and reinstall
the manager. And restore the mysql.

but I donĀ“t wat to to all the time.

Does anyone have seen it before?

Thanks


On Wed, Oct 14, 2015 at 1:57 PM, Luciano Castro <luciano.castro@gmail.com>
wrote:

> And after (second time that happened to me today...)
>
> I reboot the CS Manager, and the log shows me:
>
> 2015-10-14 16:55:09,173 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for scripts/vm/systemvm/injectkeys.sh
> in /usr/share/cloudstack-common/scripts/vm/systemvm/injectkeys.sh
> 2015-10-14 16:55:09,176 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in the classpath
> 2015-10-14 16:55:09,176 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) System resource: null
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Classpath resource: null
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Current binaries reside at
> /usr/share/cloudstack-management/webapps/client/WEB-INF/lib
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/webapps/client/WEB-INF/lib/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/webapps/client/WEB-INF/lib/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/webapps/client/WEB-INF/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/webapps/client/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/webapps/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-management/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /vms/systemvm.iso
> 2015-10-14 16:55:09,177 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Searching in environment.properties
> 2015-10-14 16:55:09,178 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) environment.properties says scripts should be
> in /usr/share/cloudstack-common
> 2015-10-14 16:55:09,178 DEBUG [c.c.u.s.Script]
> (localhost-startStop-1:null) Looking for vms/systemvm.iso in
> /usr/share/cloudstack-common/vms/systemvm.iso
> 2015-10-14 16:55:09,178 DEBUG [c.c.s.ConfigurationServerImpl]
> (localhost-startStop-1:null) Executing: /bin/bash
> /usr/share/cloudstack-common/scripts/vm/systemvm/injectkeys.sh
> /var/cloudstack/management/.ssh/id_rsa.pub
> /var/cloudstack/management/.ssh/id_rsa
> /usr/share/cloudstack-common/vms/systemvm.iso
> 2015-10-14 16:55:09,208 DEBUG [c.c.s.ConfigurationServerImpl]
> (localhost-startStop-1:null) Exit value is 1
> 2015-10-14 16:55:09,208 DEBUG [c.c.s.ConfigurationServerImpl]
> (localhost-startStop-1:null) sudo: a password is required
> 2015-10-14 16:55:09,208 INFO  [c.c.s.ConfigurationServerImpl]
> (localhost-startStop-1:null) Injected public and private keys into systemvm
> iso with result : sudo: a password is required
> 2015-10-14 16:55:09,208 WARN  [c.c.s.ConfigurationServerImpl]
> (localhost-startStop-1:null) Failed to inject generated public key into
> systemvm iso sudo: a password is required
>
>
>
>
> On Wed, Oct 14, 2015 at 1:20 PM, Luciano Castro <luciano.castro@gmail.com>
> wrote:
>
>> Hi!!
>>
>> I just installed a new environment  (CS 4.5.2 and XenServer 6.5.0). I
>> deployed an VM normaly, but some hours after I tryed to deploy new one, and
>> it shows me the following error message :
>>
>>
>> 015-10-14 16:10:50,059 ERROR [c.c.v.VmWorkJobHandlerProxy]
>> (Work-Job-Executor-14:ctx-d83f147a job-98/job-99 ctx-dabe5d49) Invocatio
>> n exception, caused by:
>> com.cloud.exception.InsufficientServerCapacityException: Unable to create a
>> deployment for VM[User|i-2-14-VM
>> ]Scope=interface com.cloud.dc.DataCenter; id=1
>>
>> The entrire log of this job is attached.The picture of my dashboard
>> (attached too) shows that I have resources available. My storage primiray
>> and secondary is external NFS.
>>
>>
>> Can you help me?
>>
>> Thanks!
>>
>> --
>> Luciano Castro
>>
>
>
>
> --
> Luciano Castro
>



-- 
Luciano Castro

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message