cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken
Date Thu, 22 Oct 2015 09:57:06 GMT
Hi Erik, 

The ceph itself does not have a concept of templates as such, so it would be hard to create
the templates outside of cloudstack. I think the only requirement of ceph here would be the
ability to create a volume (which it can do successfully already as I am able to create new
vm instances) and create a clone from volume, which would be how I imagine ACS would do it
when creating a new instance from a template. 

These things are working fine as I can see from being able to create system vms. So, from
what it seems, something must be broken when ACS tries to create a template. 

I will try to do more digging to verify this issue. 

Could someone one please confirm that they are able to create templates from volumes and snapshots
on ACS and Ceph? 

Many thanks 



----- Original Message -----

From: "Erik Weber" <terbolous@gmail.com> 
To: users@cloudstack.apache.org 
Sent: Thursday, 22 October, 2015 9:34:20 AM 
Subject: Re: ACS 4.5.2 + KVM + Ceph - Template Creation is broken 

Does it work if you do it manually, ie. outside of cloudstack? 

Could quite possibly be something wrong with ceph, considering you had 
issues with VRs as well. 

-- 
Erik 

On Thu, Oct 22, 2015 at 10:26 AM, Andrei Mikhailovsky <andrei@arhont.com> 
wrote: 

> Hello guys, 
> 
> Was wondering if this is a known issue that is being addressed? 
> 
> I've got ACS 4.5.2 with KVM and Ceph rbd. I am unable to create Templates 
> from existing volumes. 
> 
> When I try to create a template from a volume (50GB in size), I have a 
> timeout error (probably about 5 - 10 minutes after it has been initiated). 
> 
> When I try to create a snapshot from the volume and following its 
> completion create a template from the snapshot, the process does not end up 
> in error. However, the template is unusable for creating virtual machines. 
> The template size ends up being in thousands of terabytes (at least 
> according to the ACS gui). 
> 
> Is this a known problem or should I open a new bug? 
> 
> P.S. I had the same issue with 4.5.1. 
> 
> Thanks 
> 
> Andrei 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message